Forum: Ruby Problem with 'gem' command

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
4ece36f71307afc00ccd73c956f2df35?d=identicon&s=25 Martyna (Guest)
on 2008-12-05 11:05
(Received via mailing list)
I have a problem with 'gem' command. When I try to use it (i.e. 'gem
install mongrel') I got the following message:

The filename, directory name, or volume label syntax is incorrect.

I thought that this is because of proxy. I set HTTP_PROXY and it
helped, but only until the restart of my computer :(
I switched off my firewall. It also didn't help.

Does anyone have any idea how to solve this problem? I really need to
install some gems to make my project work.

My configuration:

Windows XP Pro
ruby 1.8.6 (but I tried also other versions)
firewall : Symantec Endpoint Protection
gems: 1.3.1 (but I tried also other versions)

E7cff3cfd41c495e1012227d7dc24202?d=identicon&s=25 Luis Lavena (luislavena)
on 2008-12-05 19:35
(Received via mailing list)
On Dec 5, 5:02 am, Martyna <> wrote:
> Does anyone have any idea how to solve this problem? I really need to
> Martyna
Can you provide more of the output of executing the command from the
command prompt?

Also, please try this in the command prompt:

gem install mongrel --debug

And create a pastie of the output.

This topic is locked and can not be replied to.