Forum: Rails France Compatibilité Rails avec Ruby 1.8.7

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
7add1eff4adafe6012b2e719dbf2bdc7?d=identicon&s=25 Arthur Pétry (Guest)
on 2008-12-02 16:16
(Received via mailing list)
Bonjour à tous.

Je débarque un peu là, mais dans Rails < 2.2 il y a des problèmes de
compatibilité avec ruby 1.8.7 visiblement.

Je n'arrive pas à trouver à partir de quelle version exactement Rails
est compatible avec ruby 1.8.7, et j'ai trouvé étonnamment peu de
chose sur ce problème via google...

Y a quelques infos là :

  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484351#10


qui pointe sur ces modifications là :

  http://github.com/rails/rails/commit/7391f7728d96c...
  http://github.com/rails/rails/commit/4e4bcb4c6b08e...
  http://github.com/rails/rails/commit/1d18651ea36e2...
  http://github.com/rails/rails/commit/0b21ac5118c29...
  http://github.com/rails/rails/commit/549c81db4a9ca...
  http://github.com/rails/rails/commit/f67b070facef6...
  http://github.com/rails/rails/commit/db11ef9546b1a...

Je ne maîtrise pas assez github pour savoir quelles versions de rails
incluent ces modifications ;-(
Bon par contre ces modifications datent du 1er juin, c'est déjà une
bonne info !

Je me demande en fait s'il y a pas une version de rails 2.1 voire 2.0
compatible avec ruby 1.8.7 ?

A+
Arthur
2fd0206c71a1b22a9cc6293f38537461?d=identicon&s=25 Cyril Mougel (shingara)
on 2008-12-02 16:20
(Received via mailing list)
Arthur Pétry wrote:
>
>   http://github.com/rails/rails/commit/f67b070facef6...
>   http://github.com/rails/rails/commit/db11ef9546b1a...
>
> Je ne maîtrise pas assez github pour savoir quelles versions de rails
> incluent ces modifications ;-(
> Bon par contre ces modifications datent du 1er juin, c'est déjà une
> bonne info !
>
> Je me demande en fait s'il y a pas une version de rails 2.1 voire 2.0
> compatible avec ruby 1.8.7 ?
>

Le plus simple c'est de pas utiliser ruby 1.8.7. Enormément de monde
s'accorde à dire que cette version est une catastrophe :(

--
Cyril Mougel
http://blog.shingara.fr
7add1eff4adafe6012b2e719dbf2bdc7?d=identicon&s=25 Arthur Pétry (Guest)
on 2008-12-02 16:41
(Received via mailing list)
Le 2 déc. 08 à 16:19, Cyril Mougel a écrit :
> Le plus simple c'est de pas utiliser ruby 1.8.7. Enormément de monde
> s'accorde à dire que cette version est une catastrophe :(


Ah, j'en avais pas entendu parlé, va falloir que j'ai une discussion
avec mon administrateur debian alors ;-(

http://svn.ruby-lang.org/repos/ruby/tags/v1_8_7/NEWS
Ca1e596b035117dc7c41b1d99469fe91?d=identicon&s=25 Nicolas Mérouze (Guest)
on 2008-12-02 17:59
(Received via mailing list)
Le problème de Debian c'est qu'on dirait qu'ils s'en foutent
complètement de
Ruby. Donc 1.8.7 dans Lenny et dans les backports.

Dis à ton administrateur de mettre Ruby Enterprise Edition, c'est 1.8.6
avec
tous les patchs de sécurité, plus facile à installer que compiler les
sources à la main et ça inclue Rubygems.

Par contre j'ai pas rencontré de problèmes particulier avec Ruby 1.8.7
et
Rails 2.1

--
Nicolas Mérouze
54421c0fe10a968fd36fc1ece7c0b1a0?d=identicon&s=25 JD (Guest)
on 2008-12-02 18:43
(Received via mailing list)
Le mardi 02 décembre 2008 à 17:57 +0100, Nicolas Mérouze a écrit :

> Le problème de Debian c'est qu'on dirait qu'ils s'en foutent
> complètement de Ruby.

c'est un peu radical quand même de dire ça !

>  Donc 1.8.7 dans Lenny et dans les backports.
>

En version stable (etch) il me semblait que ruby était en version 1.8.6.
A confirmer.

> Dis à ton administrateur de mettre Ruby Enterprise Edition, c'est
> 1.8.6 avec tous les patchs de sécurité, plus facile à installer que
> compiler les sources à la main et ça inclue Rubygems.
>

enfin pour un admin même débutant, c'est quand même simple de compiler
ruby si besoin (./configure && make && make install)

J.
D6fe2abcee256204cc1cb45db47a3c8c?d=identicon&s=25 Martin Catty (Guest)
on 2008-12-02 18:52
(Received via mailing list)
Arthur Pétry a écrit :
> Ah, j'en avais pas entendu parlé, va falloir que j'ai une discussion
> avec mon administrateur debian alors ;-(
>
Les joies de Debian, ruby 1.8.5 en stable et 1.8.7 en unstable
et en testing.

--
Martin Catty || fuse
http://www.noremember.org | http://www.synbioz.com
Ca1e596b035117dc7c41b1d99469fe91?d=identicon&s=25 Nicolas Mérouze (Guest)
on 2008-12-02 19:09
(Received via mailing list)
2008/12/2 JD <jeremy.dierx@bouga.net>

> Donc 1.8.7 dans Lenny et dans les backports.
>
>  En version stable (etch) il me semblait que ruby était en version 1.8.6.A confirmer.
>

C'est Ruby 1.8.5 (d'où mon radicalisme) et non patché il me semble même.


>
>  Dis à ton administrateur de mettre Ruby Enterprise Edition, c'est 1.8.6
> avec tous les patchs de sécurité, plus facile à installer que compiler les
> sources à la main et ça inclue Rubygems.
>
>  enfin pour un admin même débutant, c'est quand même simple de compiler
> ruby si besoin (./configure && make && make install)
>

Et donc là tu n'as ni readline, ni ssl. Je dis pas que c'est compliqué,
je
dis juste que REE c'est plus facile, ça inclu tout, c'est à jour (et
rubygems peut être mis à jour)... Tout l'inverse d'apt.
2aa7672c7b9fd06ecb3b0213c36157b6?d=identicon&s=25 de Villamil Frédéric (Guest)
on 2008-12-02 21:25
(Received via mailing list)
Le 2 déc. 08 à 19:09, Nicolas Mérouze a écrit :

>> Dis à ton administrateur de mettre Ruby Enterprise Edition, c'est
>
>

Alors : r8ee est une horreur en 64 bits, il faut en tenir compte

Et sinon, 2 tutos pour installer du ruby 1.8.6 sous debian comme il
faut, avec ou sans mod_rails :
http://t37.net/installer-ruby-on-rails-apache-2-2-...
http://t37.net/installer-passenger-mod_rails-sous-debian

Et comme ça tu peux même installer Typo, un projet rails qu'il est
bien et qu'il est actif http://github.com/fdv/typo/commits/master (/
prosel),

--
Frédéric de Villamil
frederic@de-villamil.com                        tel: +33 (0)6 62 19 1337
http://t37.net                       Typo : http://typosphere.org
A99870c1391c39da2089649745965bda?d=identicon&s=25 Jean-François Trân (Guest)
on 2008-12-03 01:03
(Received via mailing list)
Le 2 décembre 2008 21:24, de Villamil Frédéric a écrit :

> Alors : r8ee est une horreur en 64 bits, il faut en tenir compte

Ben faut donner alors de l'argent !

http://izumi.plan99.net/blog/index.php/2008/11/22/...

--
Prochain Apéro Ruby le 11 décembre

http://twitter.com/underflow_
2aa7672c7b9fd06ecb3b0213c36157b6?d=identicon&s=25 de Villamil Frédéric (Guest)
on 2008-12-03 12:16
(Received via mailing list)
Le 3 déc. 08 à 01:03, Jean-François Trân a écrit :

>
> Le 2 décembre 2008 21:24, de Villamil Frédéric a écrit :
>
>> Alors : r8ee est une horreur en 64 bits, il faut en tenir compte
>
> Ben faut donner alors de l'argent !
>
> 
http://izumi.plan99.net/blog/index.php/2008/11/22/...


Déjà fait, sans compter mes contributions (docs, bug tracking,
support...)

--
Frédéric de Villamil
frederic@de-villamil.com                        tel: +33 (0)6 62 19 1337
http://t37.net                       Typo : http://typosphere.org
50976bd08502aa0ac6e722828abb2379?d=identicon&s=25 Frédéric Jay (Guest)
on 2008-12-03 23:22
(Received via mailing list)
Le problème de Debian c'est qu'on dirait qu'ils s'en foutent
complètement de
Ruby.
???

Je confirme : Etch Stable ---> Ruby 1.8.5



Le 3 décembre 2008 12:15, de Villamil Frédéric <fdevillamil@gmail.com> a
écrit :
2aa7672c7b9fd06ecb3b0213c36157b6?d=identicon&s=25 de Villamil Frédéric (Guest)
on 2008-12-04 17:46
(Received via mailing list)
Le 3 déc. 08 à 23:21, Frédéric Jay a écrit :

> Le problème de Debian c'est qu'on dirait qu'ils s'en foutent
> complètement de Ruby.
> ???
>
> Je confirme : Etch Stable ---> Ruby 1.8.5
>
>

En fait le "problème" de Debian, c'est qu'ils ont un cycle de
développement et d'intégration extrêmement long. Pour un admin, c'est
le pied, parce que ça assure – en théorie, et également en pratique –
une stabilité à toute épreuve. Malheureusement pour l'utilisateur qui
a besoin de paquetages à jour, voir récents, ce n'est pas vraiment ça.

Il existe cela dit un certain nombre de paquetages plus récents
"backportés" sur la version en cours. C'est le cas pour PHP / MySQL
des paquetages dotdeb maintenus par Nexen (attention, ils forcent la
migration en MySQL en 5.1 et c'est une cata), ou simpleent des
"backports". Il existe enfin une liste de paquetages "volatiles" avec
des cycles de release nécessairement très courts, comme les antivirus
ou les antispams.

Maintenant, évidemment, le problème, c'est qu'un paquet ruby à jour,
c'est du 1.8.7.

Backports : http://www.backports.org/dokuwiki/doku.php
Dotdeb : http://www.dotdeb.org/
Volatile : http://www.debian.org/volatile/

Mes deux cents.

--
Frédéric de Villamil
frederic@de-villamil.com                        tel: +33 (0)6 62 19 1337
http://t37.net                       Typo : http://typosphere.org
059ed46172a087063ce26250e44c8627?d=identicon&s=25 Fernando Perez (fernando)
on 2008-12-09 20:43
Bonjour,

Noter site http://www.digiprof.fr tourne sous Rails 2.2.2, Debian Etch
et Ruby 1.8.7 patchlevel 72 compilé à partir des sources, et idem sur
nos Mac de développement. Je viens d'ailleurs de voir que sur la version
française du site ruby-lang c'est la 1.8.6 qui est considérée comme
dernière stable...

Comment avez-vous installé Ruby?

Arthur Pétry wrote:
> Bonjour � tous.>
> Je d�barque un peu l�, mais dans Rails < 2.2 il y a des probl�mes de
> compatibilit� avec ruby 1.8.7 visiblement.
>
> Je n'arrive pas � trouver � partir de quelle version exactement Rails
> est compatible avec ruby 1.8.7, et j'ai trouv� �tonnamment peu de
> chose sur ce probl�me via google...
>
> Y a quelques infos l� :
>
>   http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484351#10
>
>
> qui pointe sur ces modifications l� :
>
>   http://github.com/rails/rails/commit/7391f7728d96c...
>   http://github.com/rails/rails/commit/4e4bcb4c6b08e...
>   http://github.com/rails/rails/commit/1d18651ea36e2...
>   http://github.com/rails/rails/commit/0b21ac5118c29...
>   http://github.com/rails/rails/commit/549c81db4a9ca...
>   http://github.com/rails/rails/commit/f67b070facef6...
>   http://github.com/rails/rails/commit/db11ef9546b1a...
>
> Je ne ma�trise pas assez github pour savoir quelles versions de rails
> incluent ces modifications ;-(
> Bon par contre ces modifications datent du 1er juin, c'est d�j� une
> bonne info !
>
> Je me demande en fait s'il y a pas une version de rails 2.1 voire 2.0
> compatible avec ruby 1.8.7 ?
>
> A+
> Arthur
059ed46172a087063ce26250e44c8627?d=identicon&s=25 Fernando Perez (fernando)
on 2008-12-09 20:46
>> Je d�barque un peu l�, mais dans Rails < 2.2 il y a des probl�mes de
>> compatibilit� avec ruby 1.8.7 visiblement.
Pardon je viens juste de me rendre compte du "Rails < 2.2.2", pour ça je
ne sais pas, nous sommes passé de Ruby 1.8.6 à 1.8.7 avec Rails 2.2.2.
This topic is locked and can not be replied to.