Forum: Ruby on Rails SMTP Mailer is KILLING me

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
981dc6a487197fb5a91bb038d0631354?d=identicon&s=25 Patrick L. (greenguy109)
on 2008-11-29 09:49
Folks, the first person to figure this one out will make my day. Let's
just say I've tried everything for the past few hours, and I've become
frustrated to the point of forum-posting. So...ready? Here goes...

I keep getting this error: "553 This SMTP server requires authorisation.
The password you've entered is incorrect"
-> http://pastie.org/326542

Only thing is the password IS correct. I checked with my web hoster. So
I began some trial and error...like deleting the smtp information from
the development.rb page.  Nothing happened - same error.

I'm really stumped. Here's everything I'm working with.

-> My "signups" controller: http://pastie.org/326541
-> My development.rb file: http://pastie.org/326538
-> My mailer: http://pastie.org/326539
-> The associated view: http://pastie.org/326540

Please - any help would be greatly appreciated.

Cheers.
41cc2c53544016a86472343ab3fdc0ff?d=identicon&s=25 Simon Macneall (Guest)
on 2008-11-29 10:04
(Received via mailing list)
one dumb question, and this has caught me before, you are restarting
after
changing settings?


On Sat, 29 Nov 2008 17:49:36 +0900, Patrick Leahy
981dc6a487197fb5a91bb038d0631354?d=identicon&s=25 Patrick L. (greenguy109)
on 2008-11-29 10:25
Simon Macneall wrote:
> one dumb question, and this has caught me before, you are restarting
> after
> changing settings?
>
>
> On Sat, 29 Nov 2008 17:49:36 +0900, Patrick Leahy

...

Yeah. Turns out that did it. Unbelievable. Thank you.

=)
This topic is locked and can not be replied to.