Forum: Ruby on Rails script/dbconsole

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Cee2168acd7a6d8d097962b82b914557?d=identicon&s=25 railsfid@gmail.com (Guest)
on 2008-11-26 01:22
(Received via mailing list)
I'm running rails 2.2.2. Is script/dbconsole part of this or do I have
to somehow install it?

When I run script/dbconsole I get:

-bash: script/dbconsole: No such file or directory

But running script/console I do get:

script/console
Loading development environment (Rails 2.1.1)
3d6e548fa413cb093009599b24ff51d6?d=identicon&s=25 Duilio Ruggiero (sinetris)
on 2008-11-26 01:33
railsfid@gmail.com wrote:
> I'm running rails 2.2.2. Is script/dbconsole part of this or do I have
> to somehow install it?
>
> When I run script/dbconsole I get:
>
> -bash: script/dbconsole: No such file or directory
>
> But running script/console I do get:
>
> script/console
> Loading development environment (Rails 2.1.1)

modify RAILS_GEM_VERSION  in config/environment.rb

RAILS_GEM_VERSION = '2.2.2' unless defined? RAILS_GEM_VERSION

then execute:
rake rails:update

I hope this help.

Duilio Ruggiero
24d2f8804e6bb4b7ea6bd11e0a586470?d=identicon&s=25 Jeremy Kemper (Guest)
on 2008-11-26 01:33
(Received via mailing list)
On Tue, Nov 25, 2008 at 4:22 PM, railsfid@gmail.com <railsfid@gmail.com>
wrote:
>
> I'm running rails 2.2.2. Is script/dbconsole part of this or do I have
> to somehow install it?

rake rails:update

jeremy
Cee2168acd7a6d8d097962b82b914557?d=identicon&s=25 railsfid@gmail.com (Guest)
on 2008-11-26 01:41
(Received via mailing list)
That did it. Thanks!
This topic is locked and can not be replied to.