Forum: Ruby Nokogiri problem on Mac OS X

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Dd3edf8c4d5edce2cfb1975edd4ff552?d=identicon&s=25 Diogo Terror (Guest)
on 2008-11-21 18:57
(Received via mailing list)
I'm trying to install Merb, first thing I got was an issue with
sqlite3, but I fixed that by re-installing both the sqlite3 and
datamapper.
Now I'm having an issue with nokogiri. Here's the problem:

dyld: NSLinkModule() error
dyld: Symbol not found: _xmlTextReaderConstXmlVersion

I'm on Mac OS X 10.4 Ruby 1.8.6 and yes, I've got libxml, libxml2,
libxslt and their respective -devs

Any clues?
Be30361bb0b0c495e3077db43ad84b56?d=identicon&s=25 Aaron Patterson (Guest)
on 2008-11-22 04:19
(Received via mailing list)
On Sat, Nov 22, 2008 at 02:52:48AM +0900, Diogo Terror wrote:
> Any clues?
Did you install via ports?  Do you know what version of libxml2 you have
installed?

Do you mind filing a ticket?

http://nokogiri.lighthouseapp.com/projects/19607-n...
Dd3edf8c4d5edce2cfb1975edd4ff552?d=identicon&s=25 Diogo Terror (Guest)
on 2008-11-24 01:47
(Received via mailing list)
On Nov 21, 2008, at 15:52 , Diogo Terror wrote:

>
> Any clues?
>

libxml2  2.6.30-1001

Sure, I'll do that. I'll also investigate further to try and solve it.
Dd3edf8c4d5edce2cfb1975edd4ff552?d=identicon&s=25 Diogo Terror (Guest)
on 2008-11-25 14:38
(Received via mailing list)
Just for the record (literaly) this issue was solved. It was caused
because Mac OS X 10.4 libxml2 is 'slightly' broken. All you need to
do is to get a new one, through macports, fink ou building your own.

Thanks a lot to Aaron Patterson for helping me out.
This topic is locked and can not be replied to.