Forum: Ruby on Rails echoe requires RubyGems version >= 1.2

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
D3fe2dc4435cdd79e58d3e1380a557a1?d=identicon&s=25 Ruby Freak (Guest)
on 2008-11-20 06:04
(Received via mailing list)
I keep getting this error when attempting to install just about
anything.
I can't find anything about it via google.

Thanks in advance.
D3fe2dc4435cdd79e58d3e1380a557a1?d=identicon&s=25 Ruby Freak (Guest)
on 2008-11-20 07:01
(Received via mailing list)
I can't update my gems to 1.2

I have tried about everything.
gem update --system fails

early in the --debug I get:
"invalid Gem::Specification format ["1.2.0", 3, "flow"....."

followed by a series of errors
and then it finally says:
nothing to update

I did an update of ruby to no avail
sudo gem update ruby
It did update a lot of stuff, but gem update --system still fails
Gems updated: columnize, linecache, ruby-debug-base, ruby-debug,
columnize, linecache, ruby-debug-base, ruby-debug, ruby-debug-base,
ruby-debug-ide

Eric Hodel's page doesn't mention anything except gem update --system

me => :stuck
D3fe2dc4435cdd79e58d3e1380a557a1?d=identicon&s=25 Ruby Freak (Guest)
on 2008-11-20 07:43
(Received via mailing list)
OK,
I found it
sudo gem install rubygems-update
then
sudo update_rubygems

This was on Ubuntu Hardy Heron.
This topic is locked and can not be replied to.