Forum: Ruby on Rails How to read the logs?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Cee2168acd7a6d8d097962b82b914557?d=identicon&s=25 railsfid@gmail.com (Guest)
on 2008-11-18 21:38
(Received via mailing list)
Can anyone tell me where I can learn how to read and decipher the
logs? I've done a few google searches and nothing comes up.

Specifically, I just uploaded my first app to a production server and
it doesn't work and I got the following even though it works perfectly
fine on my development machine:

ctionView::TemplateError (uninitialized constant
Err::Acts::Textiled::ClassMethods::RedCloth) on line #26 of viewer/
show.html.erb:
23:
24: <% else %>
25:
26:     <%= @page.body %>
27:
28: <% end %>
   /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/
active_support/dependencies.rb:276:in `load_missing_constant'
   /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/
active_support/dependencies.rb:468:in `const_missing'
   /home/admin/book/vendor/plugins/acts_as_textiled/lib/
acts_as_textiled.rb:24:in `body'
   /home/admin/book/app/views/viewer/show.html.erb:26:in
`_run_erb_47app47views47viewer47show46html46erb'
81b61875e41eaa58887543635d556fca?d=identicon&s=25 Frederick Cheung (Guest)
on 2008-11-18 21:43
(Received via mailing list)
railsfid@gmail.com wrote:
> Can anyone tell me where I can learn how to read and decipher the
> logs? I've done a few google searches and nothing comes up.
>
> Specifically, I just uploaded my first app to a production server and
> it doesn't work and I got the following even though it works perfectly
> fine on my development machine:

I'm not sure there's any substitute for just good old fashioned
experience. In this case there's a missing RedCloth library - I'd
guess you're missing the redcloth gem on your server.

Fred
247cd3d37084a3d6794076207bd9fbd7?d=identicon&s=25 Bobnation (Guest)
on 2008-11-18 23:49
(Received via mailing list)
I can vouch for this. I haven't been reading logs for long, but I'm
getting better the more I do it ... which is bad, because it means I'm
making a lot of mistakes. I digress however.

It does look like you are missing the RedCloth gem on your production
server.

On Nov 18, 2:42 pm, Frederick Cheung <frederick.che...@gmail.com>
Cee2168acd7a6d8d097962b82b914557?d=identicon&s=25 railsfid@gmail.com (Guest)
on 2008-11-21 08:27
(Received via mailing list)
The RedCloth gem is installed:
RedCloth (4.1.1, 4.1.0)

That's why I'm going nuts trying to figure this out.
81b61875e41eaa58887543635d556fca?d=identicon&s=25 Frederick Cheung (Guest)
on 2008-11-21 11:59
(Received via mailing list)
On 21 Nov 2008, at 07:27, railsfid@gmail.com wrote:

>
> The RedCloth gem is installed:
> RedCloth (4.1.1, 4.1.0)
>
> That's why I'm going nuts trying to figure this out.
>
Then presumably something is stopping it loading. Acts as textile
swallows the load error, so I'd start by just loading rubygems in irb
and try to require RedCloth.

Fred
This topic is locked and can not be replied to.