Forum: JRuby a problem with warbler

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
0f7a5788ce4f741fd9fd3a27b68da540?d=identicon&s=25 khaled.habache (Guest)
on 2008-11-08 11:22
(Received via mailing list)
Hi,
I'm trying : jruby -S warble war --trace , am getting this:

cp
/home/khelll/projects/jruby/lib/ruby/gems/1.8/specifications/jruby-ldap-0.0.1.gemspec
tmp/war/WEB-INF/gems/specifications/jruby-ldap-0.0.1.gemspec
rake
aborted!

wrong number of arguments(2 for
3)

/home/khelll/projects/jruby/lib/ruby/site_ruby/1.8/rubygems/format.rb:50:in
`from_file_by_path'
/home/khelll/projects/jruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:114:in
`initialize'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/warbler-0.9.11/lib/warbler/task.rb:286:in
`define_single_gem_tasks'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:615:in
`call'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:615:in
`execute'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in
`each'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in
`execute'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:578:in
`invoke_with_call_chain'
/home/khelll/projects/jruby/lib/ruby/1.8/monitor.rb:191:in
`mon_synchronize'

/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in
`invoke_with_call_chain'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:564:in
`invoke'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/warbler-0.9.11/lib/warbler/task.rb:278:in
`define_single_gem_tasks'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:in
`call'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:in
`execute'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in
`each'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in
`execute'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:578:in
`invoke_with_call_chain'
/home/khelll/projects/jruby/lib/ruby/1.8/monitor.rb:191:in
`mon_synchronize'

/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in
`invoke_with_call_chain'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:588:in
`invoke_prerequisites'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
`each'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
`invoke_prerequisites'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:577:in
`invoke_with_call_chain'
/home/khelll/projects/jruby/lib/ruby/1.8/monitor.rb:191:in
`mon_synchronize'

/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in
`invoke_with_call_chain'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:588:in
`invoke_prerequisites'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
`each'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
`invoke_prerequisites'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:577:in
`invoke_with_call_chain'
/home/khelll/projects/jruby/lib/ruby/1.8/monitor.rb:191:in
`mon_synchronize'

/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in
`invoke_with_call_chain'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:588:in
`invoke_prerequisites'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
`each'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
`invoke_prerequisites'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:577:in
`invoke_with_call_chain'
/home/khelll/projects/jruby/lib/ruby/1.8/monitor.rb:191:in
`mon_synchronize'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in
`invoke_with_call_chain'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:564:in
`invoke'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2019:in
`invoke_task'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in
`top_level'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in
`each'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in
`top_level'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in
`standard_exception_handling'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1991:in
`top_level'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/warbler-0.9.11/bin/warble:67
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in
`standard_exception_handling'
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/warbler-0.9.11/bin/warble:26
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/warbler-0.9.11/bin/warble:19:in
`load'
/home/khelll/projects/jruby/bin/warble:19
khelll@khelll-laptop:~/projects/jd1g$
526d60de6472502bb570a9df2842b33b?d=identicon&s=25 Nick Sieger (Guest)
on 2008-11-08 16:06
(Received via mailing list)
On Sat, Nov 8, 2008 at 5:21 AM, khaled. habache
<khaled.habache@d1gcorp.com> wrote:
> /home/khelll/projects/jruby/lib/ruby/site_ruby/1.8/rubygems/format.rb:50:in
> `from_file_by_path'
> /home/khelll/projects/jruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:114:in
> `initialize'
> 
/home/khelll/projects/jruby/lib/ruby/gems/1.8/gems/warbler-0.9.11/lib/warbler/task.rb:286:in
> `define_single_gem_tasks'

What version of JRuby are you using? The most recent JRuby has
Rubygems 1.3 which may have some compatibility issues with Warbler.
Can you describe the steps you used to create this problem so I can
try to reproduce?

Thanks,
/Nick

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
C6b63e9914149409d4b007918649ae65?d=identicon&s=25 Khaled Al Habache (khelll)
on 2008-11-08 16:25
(Received via mailing list)
i'm using : jruby 1.1.5 and warbler-0.9.11, the project is working on
mongrel server , put when trying to use warbler it fails...
Do you need any further information?
___________________________
Eng Khaled al Habache
6bc4ddbf19386b0b2b823b194efac524?d=identicon&s=25 Ivan Schneider (isc)
on 2008-12-01 14:50
Any update on this matter ? We're willing to try out deploying an app
recently upgraded Rails 2.2 on JRuby but we are stuck at the war
generation with the same stack trace as above.
The setup is the same; JRuby 1.1.5, RubyGems 1.3.1 and Warbler 0.9.11.
This topic is locked and can not be replied to.