Forum: JRuby JRuby JDK Requirement?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
5f19a61c59692713f86abf93c5cfe9c1?d=identicon&s=25 Ray Krueger (Guest)
on 2008-11-07 16:46
(Received via mailing list)
I've been all over the website, wiki, and faq trying to find the
supported JDK version for JRuby.
I'm assuming that JRuby requires JDK 1.5 or better due to the following
error...

$jruby --help
Exception in thread "main" java.lang.NoClassDefFoundError:
java/lang/Enum
       at
org.jruby.RubyInstanceConfig.<init>(RubyInstanceConfig.java:119)
       at org.jruby.Main.<init>(Main.java:77)
       at org.jruby.Main.main(Main.java:81)

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
5a579b3ae2e98ebcc09403f38a390216?d=identicon&s=25 Matt Burke (Guest)
on 2008-11-07 17:02
(Received via mailing list)
From what I recall, jruby 1.1 moved the minimum java version from 1.4.2
to 1.5/java5.

Ray Krueger wrote:
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
Ff168162d53e22788d576582b3527e97?d=identicon&s=25 Bill Kocik (Guest)
on 2008-11-07 17:03
(Received via mailing list)
On  7 Nov, 2008, at 10:45 AM, Ray Krueger wrote:

> I've been all over the website, wiki, and faq trying to find the
> supported JDK version for JRuby.

The README file distributed with JRuby mentions this:

== Compiling from source

You will need:

* JDK 1.5 or greater

I know you're not trying to compile it, but if it compiles with 1.5
then it will run with 1.5.

--
Bill Kocik






---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
6afd2be8ba1e1ee06ef86200c7fefdf5?d=identicon&s=25 David Christiansen (Guest)
on 2008-11-07 17:05
(Received via mailing list)
I've had trouble with 1.5 and have to use 1.6 for my app.

On Fri, Nov 7, 2008 at 11:02 AM, Bill Kocik <bkocik@gmail.com> wrote:

>
>
>
>


--
David Christiansen

dave@techdarkside.com
www.techdarkside.com
317-966-6154 (mobile)
Fc19147e89d6521f92ef9e2c1c4dac24?d=identicon&s=25 Matthew Kanwisher (Guest)
on 2008-11-07 17:06
(Received via mailing list)
I've had a few apps in production running on JDK 1.5, and my dev box is
OSX
so only 1.5 ;) so I can say for sure you can run it fine in 1.5.

On Fri, Nov 7, 2008 at 11:04 AM, David Christiansen
5f19a61c59692713f86abf93c5cfe9c1?d=identicon&s=25 Ray Krueger (Guest)
on 2008-11-07 17:35
(Received via mailing list)
>
> * JDK 1.5 or greater
>
> I know you're not trying to compile it, but if it compiles with 1.5 then it
> will run with 1.5.
>
> --
> Bill Kocik
>

Aaah yes, the README, didn't look in there. Thanks.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
This topic is locked and can not be replied to.