Forum: Ruby on Rails HAproxy not listening to all IP address

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
137f06de2f189015dc8c0b2cc2a161f6?d=identicon&s=25 deepu (Guest)
on 2008-11-04 10:29
(Received via mailing list)
guys,
         i am trying to install  HAproxy infront of my webserver.
usually my webserver listens on port 80 and since we have 5 ip address
serving 5 different sites on the same physical server the webserver
listens to all these ips and proxy the traffic to the relavent app
servers.

now the problem is if want to loadbalance i should install HAproxy on
port 80 and there lies the problem. Because HAproxy as i know after
going through the config files for the last 2 days doesn't listen to
more than one ip. now since i have traffic related to 5 ips coming on
one port i have no clue how to make HAProxy listen to all that traffic
and then proxy that to their app servers.

i am really amused HAproxy listens to only one ip per port.

looking for help from you guys.

Cheers,
Deepu.
A91bd6cef23eb3516245a092e196c4da?d=identicon&s=25 Maurício Linhares (mauricio)
on 2008-11-04 12:11
(Received via mailing list)
Make HAproxy listen for the 0.0.0.0 IP, this will make it listen on
all possible IPs for your machine.

-
Maurício Linhares
http://alinhavado.wordpress.com/ (pt-br) | http://blog.codevader.com/
(en)
João Pessoa, PB, +55 83 8867-7208
This topic is locked and can not be replied to.