Forum: NGINX FastCGI response headers issue

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
80eb99fabebcddd62e6144d5ed974aee?d=identicon&s=25 Florian Schulze (Guest)
on 2008-11-02 08:33
(Received via mailing list)
Hi!

I'm using nginx 0.6.32 to serve a PHP application through FastCGI. For
some reason nginx doesn't seem to forward the Content-Type,
Content-Length
and Content-Encoding response headers. This causes javascript and css
served by a php script to fail in Safari, cause it's delivered as
text/html with Content-Length 0. Is there any configuration setting I'm
missing, or is this a bug?

Regards,
Florian Schulze
Fda08117336cfde6562315df04b976e8?d=identicon&s=25 Dave Cheney (Guest)
on 2008-11-03 01:50
(Received via mailing list)
Hi Florian,

Can you please post the config you are using to connect nginx to your
backend FCGI servers.

Cheers

Dave

On Sun, 02 Nov 2008 00:45:33 +0100, Florian Schulze
<florian.schulze@gmx.net> wrote:
> Hi!
>
> I'm using nginx 0.6.32 to serve a PHP application through FastCGI. For
> some reason nginx doesn't seem to forward the Content-Type,
Content-Length
80eb99fabebcddd62e6144d5ed974aee?d=identicon&s=25 Florian Schulze (Guest)
on 2008-11-03 12:30
(Received via mailing list)
On Mon, 03 Nov 2008 01:39:41 +0100, Dave Cheney
<dave@cheney.net> wrote:

>
> Hi Florian,
>
> Can you please post the config you are using to connect nginx to your
> backend FCGI servers.

I slightly changed the config and now it works, not sure why though :/

Regards,
Florian Schulze
This topic is locked and can not be replied to.