Forum: Ruby on Rails rails newbie - `gem_original_require': no such file to load -- /home/aa/rb1/config/environment (Loa

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
0e09c32f00d7bf688c6d34db7d7d196a?d=identicon&s=25 Cristian (Guest)
on 2008-11-02 01:45
(Received via mailing list)
Hello, I'm trying to get started with Rails but I keep getting the
same error, could someone please enlighten me?



$ mongrel_rails mongrel::start -p 8000 -l mongrel.log -P mongrel.pid -
n 5 -e development -c /home/aa/rb1/
** Ruby version is not up-to-date; loading cgi_multipart_eof_fix
** Starting Mongrel listening at 0.0.0.0:8000
** Starting Rails with development environment...
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require': no such file to load -- /home/aa/rb1/config/
environment (LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/rails.rb:147:in `rails'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:113:in `cloaker_'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/configurator.rb:149:in `call'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/configurator.rb:149:in `listener'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:99:in `cloaker_'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/configurator.rb:50:in `call'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/configurator.rb:50:in `initialize'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:84:in `new'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:84:in `run'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/command.rb:212:in `run'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:281
        from /usr/bin/mongrel_rails:19:in `load'
        from /usr/bin/mongrel_rails:19


I tried it both on Windows and CentOS and I get the same error.

thanks much!
Cristian
A91bd6cef23eb3516245a092e196c4da?d=identicon&s=25 Maurício Linhares (mauricio)
on 2008-11-02 04:51
(Received via mailing list)
What happens if you get into the "/home/aa/rb1" directory and type
"script/server"?

-
Maurício Linhares
http://alinhavado.wordpress.com/ (pt-br) | http://blog.codevader.com/
(en)
João Pessoa, PB, +55 83 8867-7208
This topic is locked and can not be replied to.