Forum: Ruby on Rails Can not install sqlite3-ruby

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
332edc8afd6760765bc112cb52fdc63f?d=identicon&s=25 Khaled mahmud Khaled (khaled200)
on 2008-10-28 10:30
Hi Friends,

I could not setup sqlite3. When I type "gem install sqlite3-ruby
--version 1.2.4" in the command prompt. The following problem is
arising.

C:\>gem install sqlite3-ruby --version 1.2.4
Building native extensions. This could take a while…
ERROR: Error installing sqlite3-ruby:
ERROR: Failed to build gem native extension.

c:/ruby/bin/ruby.exe extconf.rb install sqlite3-ruby
checking for fdatasync() in rt.lib… no
checking for sqlite3.h… no

nmake
‘nmake’ is not recognized as an internal or external command,
operable program or batch file.

Gem files will remain installed in
c:/ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.4 for inspection.
Results logged to
c:/ruby/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.2.4/ext/sqlite3_
api/gem_make.out

after that I went to that specific folder
("C:\ruby\lib\ruby\gems\1.8\gems") and saw there is already a folder
named "sqlite3-ruby-1.2.4"  installed.

Please help me. I am very much interested to work with Ruby on Rails but
I could not work with that because of that problem.

Thanks in advance.

Roni
34a7615f38496a5dafbb3e6b721c435e?d=identicon&s=25 Mohit Sindhwani (Guest)
on 2008-10-28 15:31
(Received via mailing list)
Khaled mahmud Khaled wrote:
> Hi Friends,
>
> I could not setup sqlite3. When I type "gem install sqlite3-ruby
> --version 1.2.4" in the command prompt. The following problem is
> arising.
>
On Windows, I think you need 1.2.3 - so you should do:
gem install sqlite3-ruby --version 1.2.3

That should get it working.

Cheers,
Mohit.
10/28/2008 | 10:29 PM.
This topic is locked and can not be replied to.