Forum: Rails deployment Can't Activate Capistrano Error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
E25296bf52723dc37bc462271eb02d2d?d=identicon&s=25 Jason Pfeifer (jpfeifer)
on 2008-10-22 22:11
Greetings,

I'm getting an error when trying to do a "cap staging deploy" from the
command line:

$ cap staging deploy
/Library/Ruby/Site/1.8/rubygems.rb:147:in `activate': can't activate
capistrano (= 2.4.3, runtime), already activated capistrano-2.5.0
(Gem::Exception)
  from /Library/Ruby/Site/1.8/rubygems.rb:163:in `activate'
  from /Library/Ruby/Site/1.8/rubygems.rb:162:in `each'
  from /Library/Ruby/Site/1.8/rubygems.rb:162:in `activate'
  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
  from
/Users/jasonpfeifer/.gem/ruby/1.8/gems/capistrano-2.5.0/lib/capistrano/configuration/loading.rb:152:in
`require'
  from Capfile:3:in `load'
  from
/Users/jasonpfeifer/.gem/ruby/1.8/gems/capistrano-2.5.0/lib/capistrano/configuration/loading.rb:172:in
`load_from_file'
  from
/Users/jasonpfeifer/.gem/ruby/1.8/gems/capistrano-2.5.0/lib/capistrano/configuration/loading.rb:89:in
`load'
   ... 7 levels...
  from
/Users/jasonpfeifer/.gem/ruby/1.8/gems/capistrano-2.5.0/lib/capistrano/cli/execute.rb:14:in
`execute'
  from /Users/jasonpfeifer/.gem/ruby/1.8/gems/capistrano-2.5.0/bin/cap:4
  from /usr/bin/cap:19:in `load'
  from /usr/bin/cap:19

My environment is thus:

rubygems 1.3.0
capistrano (2.5.0, 2.4.3, 2.0.0)
capistrano-ext (1.2.0)
Rails 2.1.1

I've done some googling and found similar problems as in here:
http://groups.google.com/group/capistrano/browse_t...

However they don't necessarily seem to apply to me.  The solution there
seems to be commenting out a line that loads "deprec", but I can't seem
to find the .caprc file on my system if that's it.

Help is appreciated.

Regards,

Jason
A82ba1167f4d4a8d1de63820e576a87f?d=identicon&s=25 Robby Russell (Guest)
on 2008-10-23 03:23
(Received via mailing list)
Jason,

It looks like something is requiring capistrano 2.4.3. Might check in
your deployment config files for that.

Robby

On Wed, Oct 22, 2008 at 1:11 PM, Jason Pfeifer
<ruby-forum-incoming@andreas-s.net> wrote:
>  from /Library/Ruby/Site/1.8/rubygems.rb:163:in `activate'
>  from
> My environment is thus:
> seems to be commenting out a line that loads "deprec", but I can't seem
> >
>



--
Robby Russell
Chief Evangelist, Partner

PLANET ARGON, LLC
design // development // hosting

http://www.planetargon.com/
http://www.robbyonrails.com/
aim: planetargon

+1 503 445 2457
+1 877 55 ARGON [toll free]
+1 815 642 4068 [fax]
This topic is locked and can not be replied to.