Forum: Ruby Need help to install "linguistics" gem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
9239e324751b8db551789e5e16689438?d=identicon&s=25 Hunt Jon (Guest)
on 2008-10-17 05:00
(Received via mailing list)
Hi,

I have a problem with installing gem: linguistics.

sudo gem install linguistics

Gave me "not found" error. So I googled and found the source here.
http://www.deveiate.org/projects/Linguistics/
The gem seems to be located at
http://www.deveiate.org/code/Linguistics-1.0.5.gem

I don't know how I can install this gem.

Can any body help on this?

-J
C1138881c3c40b21e9415a3c1fdd3a0b?d=identicon&s=25 Victor Goff (kotp)
on 2008-10-17 05:13
(Received via mailing list)
Simply download it to your local drive... then do something like
this:bash-3.2$
cd /cygdrive/d/Downloads/
bash-3.2$ gem install Linguistics-1.0.5.gem
Successfully installed Linguistics-1.0.5
1 gem installed

Specifically, for this instance, it was done on Windows using my Cygwin
environment.
45196398e9685000d195ec626d477f0e?d=identicon&s=25 Thomas Sawyer (7rans)
on 2008-10-17 05:17
(Received via mailing list)
On Oct 16, 10:59 pm, "Hunt Jon" <jona.hunt...@gmail.com> wrote:
> Hi,
>
> I have a problem with installing gem: linguistics.
>
> sudo gem install linguistics
>
> Gave me "not found" error. So I googled and found the source 
here.http://www.deveiate.org/projects/Linguistics/
> The gem seems to be located athttp://www.deveiate.org/code/Linguistics-1.0.5.gem
>
> I don't know how I can install this gem.

I'm assuming you have RubyGems installed already. Just download
the .gem file and then use a terminal/console:

Linux:

  $ sudo gem install Linguistics-1.0.5.gem

Windows:

  > gem install Linguistics-1.0.5.gem

T.
9239e324751b8db551789e5e16689438?d=identicon&s=25 Hunt Jon (Guest)
on 2008-10-17 08:02
(Received via mailing list)
I'm still getting the same error.

I downloaded the "Linguistics-1.0.5.gem.tar" file on my desktop.
Then, I double-clicked and expanded and now there is a new directory
"Linguistics-1.0.5.gem" on my desktop.
Next, I launch Terminal and `cd` to desktop. `cd ~/Desktop`.

Then, I run

sudo gem install Linguistics-1.0.5.gem

The error I get is:

ERROR:  could not find gem Linguistics-1.0.5.gem locally or in a
repository


I wonder where gem is searching locally. I may need to place  the .gem
directory somewhere specified.

I ran `gem environment` and here's output.

gem environment
RubyGems Environment:
  - RUBYGEMS VERSION: 1.2.0
  - RUBY VERSION: 1.8.7 (2008-08-11 patchlevel 72) [i686-darwin9]
  - INSTALLATION DIRECTORY: /opt/local/lib/ruby/gems/1.8
  - RUBY EXECUTABLE: /opt/local/bin/ruby
  - EXECUTABLE DIRECTORY: /opt/local/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-darwin-9
  - GEM PATHS:
     - /opt/local/lib/ruby/gems/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - :sources => ["http://gems.rubyforge.org/",
"http://gems.github.com"]
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/
     - http://gems.github.com
9239e324751b8db551789e5e16689438?d=identicon&s=25 Hunt Jon (Guest)
on 2008-10-17 08:23
(Received via mailing list)
Solved.

I opened up the directory "Linguistics-1.0.5.gem" and found two files
"metadata.tar.gz" and "data.gz".
I extracted both archives, and "cd"ed to "data" directory.

There I ran a command.

pwd #=> /Users/myusernamei/Desktop/Linguistics-1.0.5.gem/data
sudo gem install Linguistics

Now the installation was successful.

Thanks for your help, guys.
This topic is locked and can not be replied to.