Forum: Ruby on Rails NetBeans can't find OracleAdapter

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ff168162d53e22788d576582b3527e97?d=identicon&s=25 Bill Kocik (Guest)
on 2008-10-15 01:03
(Received via mailing list)
I'm sort of cross-posting the following from the NetBeans forum in
hopes that maybe someone here might have an idea:

I'm having a strange issue with the NetBeans nightly from 10/14 (and
before that, I was having the same issue with the one from 10/11). I
haven't tried 6.1 or earlier.

In a project, I have this line in my environment.rb file:

ActiveRecord::ConnectionAdapters::OracleAdapter.emulate_booleans =
false

I can start my server, run migrations, and run the console for that
project from the command line with no issues. But when I try to do any
of those things within NetBeans, I get this error:

/Users/bkocik/Dev/mydir/my_project/vendor/rails/activerecord/lib/../../
activesupport/lib/active_support/dependencies.rb:263:in
`load_missing_constant':NameError: uninitialized constant
ActiveRecord::ConnectionAdapters::OracleAdapter

NetBeans has the same GEM_HOME setting as my shell environment (I use
OS X), and neither NB nor my shell have a GEM_PATH set. I should point
out that NB doesn't seem to have issues finding other gems, it's just
this OracleAdapter one (and it's definitely installed):

$ gem list | grep oracle
activerecord-oracle-adapter (1.0.0.9250)

I'm not sure what else to try in order to resolve this. Anyone have
suggestions?

Thanks . . .
This topic is locked and can not be replied to.