Forum: wxRuby Fresh install problem.

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Eee774a82313b9081986dba418781adc?d=identicon&s=25 Svend Haugaard Sørensen (Guest)
on 2008-10-14 02:06
(Received via mailing list)
So my old computer fried a motherboard.
So after bying, building and installing my new computer.
I return to wxruby and install it via 'gem install wxruby'
and run my old programs. BUT they don't work.

They return this error.

/usr/lib/ruby/gems/1.8/gems/wxruby-1.9.8-x86-linux/lib/wxruby2.so:
/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/libstdc++.so.6:
version `GLIBCXX_3.4.9' not found (required
by /usr/lib/ruby/gems/1.8/gems/wxruby-1.9.8-x86-linux/lib/wxruby2.so)
- /usr/lib/ruby/gems/1.8/gems/wxruby-1.9.8-x86-linux/lib/wxruby2.so
(LoadError)
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
from /usr/lib/ruby/gems/1.8/gems/wxruby-1.9.8-x86-linux/lib/wx.rb:12
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in
`gem_original_require'
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in
`require' from dnet.rb:1

Is this something I can fix ?
3396e4a3df8a840faec520af8555a400?d=identicon&s=25 Mario Steele (Guest)
on 2008-10-14 02:31
(Received via mailing list)
This error means that glibc is of a different version then the one that
is
compiled with wxRuby gem.  It could be new or it could be older.  It all
depends.

The only way I can think to fix this, is to go through the self-compile
of
wxRuby.

See here to self-compile wxRuby:
http://wxruby.rubyforge.org/wiki/wiki.pl?Installin...

If you have any questions about self-compiling, feel free to ask, and I
or
someone else will be happy to help.

hth,

Mario

On Mon, Oct 13, 2008 at 8:01 PM, Svend Haugaard Sørensen
<shs@demosophia.net
This topic is locked and can not be replied to.