Forum: GNU Radio error while loading shared libraries: libusrp.so.0

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Eaf07f535e2a32277ee6db92ae16aa25?d=identicon&s=25 brandie (Guest)
on 2008-10-13 17:29
(Received via mailing list)
Hi all!

I have a strange problem to link the libusrp in C++.
I get some errors like this:
 error while loading shared libraries: libusrp.so.0: cannot open shared
object file: No such file or directory

I can find all these files

<gnuradio>/usrp/host/lib/legacy/.libs/libusrp.lai
<gnuradio>/usrp/host/lib/legacy/.libs/libusrp.so.0.0.0
<gnuradio>/usrp/host/lib/legacy/.libs/libusrp.la
<gnuradio>/usrp/host/lib/legacy/.libs/libusrp.so
<gnuradio>/usrp/host/lib/legacy/.libs/libusrp.so.0
<gnuradio>/usrp/host/lib/legacy/libusrp.la

So I am very confusing with this. I have this problem in gnuradio 3.1.2,
3.1.1 also 3.1.0. Now I am using  3.1.0 on debian. Can anyone give me
some
suggestions?

Brandie!
--
View this message in context:
http://www.nabble.com/error-while-loading-shared-l...
Sent from the GnuRadio mailing list archive at Nabble.com.
745d8202ef5a58c1058d0e5395a78f9c?d=identicon&s=25 Eric Blossom (Guest)
on 2008-10-13 18:17
(Received via mailing list)
On Mon, Oct 13, 2008 at 08:28:47AM -0700, brandie wrote:
> <gnuradio>/usrp/host/lib/legacy/.libs/libusrp.lai
> Brandie!
First off, why 3.1.0 instead of 3.1.3?  We do fix bugs...

For information on the broken version of libtool shipped with Debian
and Ubuntu, and a suggested work-around, please see
http://gnuradio.org/trac/wiki/UbuntuInstall#Broken...

Eric
Eaf07f535e2a32277ee6db92ae16aa25?d=identicon&s=25 brandie (Guest)
on 2008-10-13 20:47
(Received via mailing list)
I have the same problem in 3.1.3.
I can see all these files but can not link the lib in C++.




Eric Blossom wrote:
>> I can find all these files
>> some
> Eric
>
>
> _______________________________________________
> Discuss-gnuradio mailing list
> Discuss-gnuradio@gnu.org
> http://lists.gnu.org/mailman/listinfo/discuss-gnuradio
>
>

--
View this message in context:
http://www.nabble.com/error-while-loading-shared-l...
Sent from the GnuRadio mailing list archive at Nabble.com.
745d8202ef5a58c1058d0e5395a78f9c?d=identicon&s=25 Eric Blossom (Guest)
on 2008-10-13 21:01
(Received via mailing list)
On Mon, Oct 13, 2008 at 11:45:43AM -0700, brandie wrote:
>
> I have the same problem in 3.1.3.
> I can see all these files but can not link the lib in C++.

A. Did you do a "make install"
B. Did you read and follow the instructions here:
   http://gnuradio.org/trac/wiki/UbuntuInstall#Broken...

Eric
063614dd3613cfd90b6c86b951fcf2a4?d=identicon&s=25 Karthik Vijayraghavan (Guest)
on 2008-10-14 01:08
(Received via mailing list)
after doing "make install" try a sudo /sbin/ldconfig

Karthik
Eaf07f535e2a32277ee6db92ae16aa25?d=identicon&s=25 brandie (Guest)
on 2008-10-14 05:21
(Received via mailing list)
Thanks for your suggestion!
It works!


Karthik Vijayraghavan wrote:
>>
>> Discuss-gnuradio@gnu.org
>> http://lists.gnu.org/mailman/listinfo/discuss-gnuradio
>>
>
>
> _______________________________________________
> Discuss-gnuradio mailing list
> Discuss-gnuradio@gnu.org
> http://lists.gnu.org/mailman/listinfo/discuss-gnuradio
>
>

--
View this message in context:
http://www.nabble.com/error-while-loading-shared-l...
Sent from the GnuRadio mailing list archive at Nabble.com.
This topic is locked and can not be replied to.