Forum: Ruby on Rails gem 1.3.0, netbeans 6.1 "Missing the Rails gem"

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
8f27f50c60bbd39d81dc4acd7d3bebdb?d=identicon&s=25 Pablo Q. (pabloq)
on 2008-10-08 21:47
I'm on ubuntu 8.04 and I'm using  netbeans 6.1 with native ruby option.

root@castor-laptop:/home/castor# gem --version
1.3.0
root@castor-laptop:/home/castor# ruby --version
ruby 1.8.6 (2007-09-24 patchlevel 111) [i486-linux]

I'm able to run scripts/console from command:

root@castor-laptop:/home/castor/projects/Aflus# script/console
Loading development environment (Rails 2.1.1)
>>

but when I try to run the same from netbeans rails console I get this:

Missing the Rails  gem. Please `gem install -v= rails`, update your
RAILS_GEM_VERSION setting in config/environment.rb for the Rails version
you do have installed, or comment out RAILS_GEM_VERSION to use the
latest version installed.

I checked the configuration of the ruby platform and it looks fine....

Any idea?

--
Pablo Q.
Af2ce6689213fdb78913a9662b18da6b?d=identicon&s=25 Rick (Guest)
on 2008-10-09 03:20
(Received via mailing list)
Pablo,

I've noticed a similar problem with 6.5M and 6.5Beta.  My problem
turned out to be a NetBeans call to Rake that was failing.  I've filed
with Sun-NetBeansDev, issue 149201.

My problem was in NetBeans source ruby2/rake_tasks_info.rb.  On line 9
of that file is a call to "do_option" method on rake.  This method
appears to exist in rake v0.7.? but not in v0.8.? and rake v0.8.3 is
the one that's currently shipping.

I just commented out line 9 in the NB file and all (appears to) work
fine.

You might want to turn on your IDE logging and check that you're
having the same (rake failure) problem as without the log the info
reported leads you to believe you have a different (bigger) problem.

Rick

On Oct 8, 9:47 am, "Pablo Q." <rails-mailing-l...@andreas-s.net>
This topic is locked and can not be replied to.