Forum: NGINX 504 Gateway Time-out during POST

7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-07 18:53
(Received via mailing list)
Hello,

I seem to be getting a lot of 504 Gateway Time-out's specifically when
posting
forms.

A sample form would be 2 textboxes and a textarea each with the word
test in.
This would cause the error to come up.

Any ideas what may be causing this ?

Thank you
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-07 19:11
(Received via mailing list)
Just to go into a bit more detail:

I run a site with a fairly large forum. Since moving to nginx and
php-fpm my
server performance has got worse. I fully concede this is likely to be a
configuration issue on my part, but it's frustrating to say the least
:-)

I am getting a lot of MySQL server gone away messages which whilst I
appreciate
can be caused by a lot of things, if when POSTing and executing PHP
scripts at a
very slow rate it too can cause issues like this.

Anyone else had these sorts of issues ? I'm thinking I may have to go
back to
Apache and PHP atm :-/
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-07 20:10
(Received via mailing list)
This is affecting even non-forum pages that have to POST.

So either nginx isn't sending to php-fpm correctly, or php-fpm is not
functioning right for post requests :-/
C996e830c7dc59a5e8db36dff386325f?d=identicon&s=25 Rob Schultz (schultz)
on 2008-09-07 20:10
(Received via mailing list)
It sounds like your php-fastcgi isn't configured like your apache or
you are not running that many instances of them to handle your load.
Apache automatically forked more processes as load went up. php-
fastcgi does not so you will have to add more processes to handle the
load. Also i would recommend using php-fpm patch to php for running
your php-fastcgi instances.

So to ask how many processes of php do you have configured running?
7a7c51366e39603df74feef200a3a1c1?d=identicon&s=25 Aleksandar Lazic (Guest)
on 2008-09-07 20:10
(Received via mailing list)
On Son 07.09.2008 17:05, David wrote:
>this.
Do you have any errors in the php-error log or phpfm-error log?

>Anyone else had these sorts of issues ? I'm thinking I may have to go
>back to Apache and PHP atm :-/

Well, how much time and leisure have you to solve this issue?!

BR

Aleks
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-07 20:28
(Received via mailing list)
Hi Rob,

I am using php-fpm which I patched against php before installing php.

I've just upped my <value name="max_children">10</value> to 150
and it still 504's.

I really don't know what to try next.
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-07 20:50
(Received via mailing list)
When turning nginx logging to info I can see I am getting a lot of
these:

upstream timed out (110: Connection timed out) while reading response
header
from upstream, client:
C996e830c7dc59a5e8db36dff386325f?d=identicon&s=25 Rob Schultz (schultz)
on 2008-09-07 20:50
(Received via mailing list)
are you using the same php.ini config as you used with apache?
Basically look at your timeouts and such. And as Aleksandar mentioned
is there anything in your php-fpm logs? Also what value do you have
set for fastcgi timeout? it defaults to 1 minute i believe.
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-07 20:59
(Received via mailing list)
Hi,

No errors in php-fpm log.

I am happy to try and debug, just don't like the instability for my
users which
I am sure you can appreciate.
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-07 21:10
(Received via mailing list)
I think this is what you meant by php.ini's timeout value:

max_execution_time = 40

Prior to moving to nginx and php-fpm I have never experienced this issue
BTW.

Below is a copy of my php-fpm.conf

<?xml version="1.0" ?>
<configuration>

        All relative paths in this config are relative to php's install
prefix

        <section name="global_options">

                Pid file
                <value
name="pid_file">/usr/local/logs/php-fpm.pid</value>

                Error log file
                <value
name="error_log">/var/log/php-fpm/php-fpm.log</value>

                Log level
                <value name="log_level">notice</value>

                When this amount of php processes exited with SIGSEGV or
SIGBUS ...
                <value name="emergency_restart_threshold">10</value>

                ... in a less than this interval of time, a graceful
restart
will be initiated.
                Useful to work around accidental curruptions in
accelerator's
shared memory.
                <value name="emergency_restart_interval">1m</value>

                Time limit on waiting child's reaction on signals from
master
                <value name="process_control_timeout">5s</value>

                Set to 'no' to debug fpm
                <value name="daemonize">yes</value>

        </section>

        <workers>

                <section name="pool">

                        Name of pool. Used in logs and stats.
                        <value name="name">default</value>

                        Address to accept fastcgi requests on.
                        Valid syntax is 'ip.ad.re.ss:port' or just
'port' or
'/path/to/unix/socket'
                        <value
name="listen_address">127.0.0.1:9000</value>

                        <value name="listen_options">

                                Set listen(2) backlog
                                <value name="backlog">-1</value>

                                Set permissions for unix socket, if one
used.
                                In Linux read/write permissions must be
set in
order to allow connections from web server.
                                Many BSD-derrived systems allow
connections
regardless of permissions.
                                <value name="owner"></value>
                                <value name="group"></value>
                                <value name="mode">0666</value>
                        </value>

                        Additional php.ini defines, specific to this
pool of
workers.
                        <value name="php_defines">
                <!--            <value
name="sendmail_path">/usr/sbin/sendmail
-t -i</value>            -->
                <!--            <value name="display_errors">0</value>
                                                -->
                        </value>

                        Unix user of processes
                        <value name="user">nginx</value>

                        Unix group of processes
                        <value name="group">nginx</value>

                        Process manager settings
                        <value name="pm">

                                Sets style of controling worker process
count.
                                Valid values are 'static' and
'apache-like'
                                <value name="style">static</value>

                                Sets the limit on the number of
simultaneous
requests that will be served.
                                Equivalent to Apache MaxClients
directive.
                                Equivalent to PHP_FCGI_CHILDREN
environment in
original php.fcgi
                                Used with any pm_style.
                                <value name="max_children">100</value>

                                Settings group for 'apache-like' pm
style
                                <value name="apache_like">

                                        Sets the number of server
processes
created on startup.
                                        Used only when 'apache-like'
pm_style is
selected
                                        <value
name="StartServers">10</value>

                                        Sets the desired minimum number
of idle
server processes.
                                        Used only when 'apache-like'
pm_style is
selected
                                        <value
name="MinSpareServers">5</value>

                                        Sets the desired maximum number
of idle
server processes.
                                        Used only when 'apache-like'
pm_style is
selected
                                        <value
name="MaxSpareServers">5</value>

                                </value>

                        </value>

                        Time limit on waiting execution of single
request
                        Should be used when 'max_execution_time' ini
option does
not terminate execution for some reason
                        <value
name="request_execution_timeout">60s</value>

                        Set open file desc rlimit
                        <value name="rlimit_files">1024</value>

                        Set max core size rlimit
                        <value name="rlimit_core">0</value>

                        Chroot to this directory at the start
                        <value name="chroot"></value>

                        Chdir to this directory at the start
                        <value name="chdir"></value>

                        Redirect workers' stdout and stderr into main
error log.
                        If not set, they will be redirected to
/dev/null,
according to FastCGI specs
                        <value name="catch_workers_output">yes</value>

                        How much requests each process should execute
before
respawn.
                        Useful to work around memory leaks in 3rd party
libraries.
                        For endless request processing please specify 0
                        Equivalent to PHP_FCGI_MAX_REQUESTS
                        <value name="max_requests">500</value>

                        Comma separated list of ipv4 addresses of
FastCGI
clients that allowed to connect.
                        Equivalent to FCGI_WEB_SERVER_ADDRS environment
in
original php.fcgi (5.2.2+)
                        Makes sense only with AF_INET listening socket.
                        <value name="allowed_clients">127.0.0.1</value>

                        Pass environment variables like LD_LIBRARY_PATH
                        All $VARIABLEs are taken from current
environment
                        <value name="environment">
                                <value name="HOSTNAME">$HOSTNAME</value>
                                <value
name="PATH">/usr/local/bin:/usr/bin:/bin</value>
                                <value name="TMP">/tmp</value>
                                <value name="TMPDIR">/tmp</value>
                                <value name="TEMP">/tmp</value>
                                <value name="OSTYPE">$OSTYPE</value>
                                <value name="MACHTYPE">$MACHTYPE</value>
                                <value name="MALLOC_CHECK_">2</value>
                        </value>

                </section>

        </workers>

</configuration>
7a7c51366e39603df74feef200a3a1c1?d=identicon&s=25 Aleksandar Lazic (Guest)
on 2008-09-07 21:36
(Received via mailing list)
On Son 07.09.2008 18:53, David wrote:
>Hi,
>
>No errors in php-fpm log.
>
>I am happy to try and debug, just don't like the instability for my
>users which I am sure you can appreciate.

Of course
7a7c51366e39603df74feef200a3a1c1?d=identicon&s=25 Aleksandar Lazic (Guest)
on 2008-09-07 21:52
(Received via mailing list)
On Son 07.09.2008 19:02, David wrote:
>I think this is what you meant by php.ini's timeout value:
>
>max_execution_time = 40
>
>Prior to moving to nginx and php-fpm I have never experienced this
>issue BTW.
>
>Below is a copy of my php-fpm.conf
>

>                  Sets the limit on the number of
>                  simultaneous requests that will be served.
>                  Equivalent to Apache MaxClients directive.
>                  Equivalent to PHP_FCGI_CHILDREN environment in
>                  original php.fcgi
>                                Used with any pm_style.
>                                <value name="max_children">100</value>

100 WOW


>      Time limit on waiting execution of single request
>      Should be used when 'max_execution_time' ini option does
>      not terminate execution for some reason
>                        <value name="request_execution_timeout">60s</value>

How long is your programm running?
Maybe you must increase this ans the max_execution_time


>        How much requests each process should execute before
>        respawn.
>        Useful to work around memory leaks in 3rd party libraries.
>        For endless request processing please specify 0
>        Equivalent to PHP_FCGI_MAX_REQUESTS
>        <value name="max_requests">500</value>

How much request are done before you get the 504 error?

Which version of nginx and php?
Please can you post a output of phpinfo()?

have you such lines in your php ini file

###
error_log = <A_PATH>/php-error.log
log_errors = On
track_errors = On
###

BR

Aleks
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-07 22:13
(Received via mailing list)
Aleksandar,

I put 100 to try and eliminate too few php-fpm childs to process the
scripts.

The program itself times out after about a minute, but on Apache and
normal PHP
it used to execute instantly. It's not a looping script or anything -
just a
couple of queries and output.

Nginx: nginx-0.6.32
PHP-FPM: php-5.2.6-fpm-0.5.8.diff.gz

PHPINFO: http://www.vividdevelopment.co.uk/info.php

I will add the errorlog bits to my php.ini and update when I get some
logs.

Thanks for your assistance
7a7c51366e39603df74feef200a3a1c1?d=identicon&s=25 Aleksandar Lazic (Guest)
on 2008-09-07 22:32
(Received via mailing list)
On Son 07.09.2008 20:05, David wrote:
>Aleksandar,
>
>I put 100 to try and eliminate too few php-fpm childs to process the
>scripts.
>
>The program itself times out after about a minute, but on Apache and
>normal PHP it used to execute instantly. It's not a looping script or
>anything - just a couple of queries and output.

Pay attention some queries can be looooooooooong running queries ;-)

>Nginx: nginx-0.6.32
>PHP-FPM: php-5.2.6-fpm-0.5.8.diff.gz
>
>PHPINFO: http://www.vividdevelopment.co.uk/info.php

Thanks.

Does you application use mysql or mysqli?
After we have fix the 504 you should make the php setup safer ;-)

e. g.

http://www.php.net/manual/en/session.configuration...
http://www.php.net/manual/en/session.configuration...

>I will add the errorlog bits to my php.ini and update when I get some
>logs.

Yes, please.

>Thanks for your assistance

Your welcome.

Btw.: your libcurl is reallly old 'libcurl/7.15.5'!
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-07 22:50
(Received via mailing list)
I haven't had any errors logged yet, but will keep an eye on it. The
process
itself is still taking far too long. This is a new server - I upgraded
and took
the opportunity to try out nginx and php-fpm. This server is
considerably faster
than my last.

I have setup all my scripts to run mysqli.

I'll sort the libcurl thanks.

Is there anything I can be trying now ?
7a7c51366e39603df74feef200a3a1c1?d=identicon&s=25 Aleksandar Lazic (Guest)
on 2008-09-07 23:00
(Received via mailing list)
On Son 07.09.2008 20:43, David wrote:

>I haven't had any errors logged yet, but will keep an eye on it. The
>process itself is still taking far too long. This is a new server - I
>upgraded and took the opportunity to try out nginx and php-fpm. This
>server is considerably faster than my last.

Do you have got some 504 errors in the meantime?

>I have setup all my scripts to run mysqli.

Is it possible to check the runtime of the scripts?

e.g.: http://at.php.net/manual/en/function.microtime.php

>Is there anything I can be trying now ?

Please try to add the timing format in nginx to get a 'normal'
response time from php-fm

http://wiki.codemongers.com/NginxHttpUpstreamModule

BR

Aleks
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-07 23:36
(Received via mailing list)
No, no 502s, but it's still too slow. I'm getting a lot of these isn
nginx's
error-log.

I'm afraid I can't really use the microtime function as these aren't my
scripts.
This problem only seems to affect POST functions though I've noticed.

upstream timed out (110: Connection timed out) while reading response
header
from upstream
7a7c51366e39603df74feef200a3a1c1?d=identicon&s=25 Aleksandar Lazic (Guest)
on 2008-09-07 23:40
(Received via mailing list)
On Son 07.09.2008 21:15, David wrote:
>No, no 502s, but it's still too slow. I'm getting a lot of these isn
>nginx's error-log.
>
>I'm afraid I can't really use the microtime function as these aren't my
>scripts.
>This problem only seems to affect POST functions though I've noticed.
>
>upstream timed out (110: Connection timed out) while reading response
>header from upstream

How about the timing log?
Are this a public scripts or a private scripts?
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-07 23:40
(Received via mailing list)
Sorry I meant 504's and that I haven't received one but others have. I
can tell
this from my nginx error log (see error in previous post), and there is
nothing
in PHP error log or php-fpm error log
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-07 23:43
(Received via mailing list)
It's vbulletin (vbulletin.org)

BTW just a thought I had when looking at my php.ini ...

I moved my MySQL to a different drive and moved my mysql.sock In php.ini
it
looks like it's looking at the wrong one, and /var/lib/mysql/mysql.ini
which I
thought was symlinked but it's not. Could this be causing the speed
problem ?
7f006226eff37eaa07b1e8b96f521cb2?d=identicon&s=25 Kiril Angov (Guest)
on 2008-09-07 23:44
(Received via mailing list)
Maybe not related but... when I tried to run phpMyAdmin under php-fpm
and mysqli (notice it is a problem with MySQLi), I was getting random
and very often 504 errors because the php was sigfaulting. I am pretty
sure it is not an nginx problem but more the fact that you have PHP
now running as fastcgi rather than mod_php.

Please, take a closer look at nginx's error log and if the server is
not in production or just quickly run php-cgi without php-fpm like
this:

php-cgi -b 127.0.0.1:9000

Do not make it go in daemon mode so that you can see on the console if
it dies.

HTH,
Kiril
7a7c51366e39603df74feef200a3a1c1?d=identicon&s=25 Aleksandar Lazic (Guest)
on 2008-09-07 23:44
(Received via mailing list)
On Son 07.09.2008 21:30, David wrote:
>It's vbulletin (vbulletin.org)
>
>BTW just a thought I had when looking at my php.ini ...
>
>I moved my MySQL to a different drive and moved my mysql.sock In
>php.ini it looks like it's looking at the wrong one, and
>/var/lib/mysql/mysql.ini which I thought was symlinked but it's
>not. Could this be causing the speed problem ?

I don't think so.

Do you have any information about the timing ;-)
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-07 23:44
(Received via mailing list)
vbulletin.com
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-08 00:06
(Received via mailing list)
I now have this in my nginx.conf is this what you meant ? Does this log
to the
same error_log ?

    log_format  main  '$remote_addr - $remote_user [$time_local]
$request '
                      '"$status" $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

log_format timing '$remote_addr - $remote_user [$time_local] $request '
                  'upstream_response_time $upstream_response_time '
                  'msec $msec request_time $request_time';
4b2c18dd9e134a2cef3d4026dc3e580d?d=identicon&s=25 Aleksandar Lazic (Guest)
on 2008-09-08 00:15
(Received via mailing list)
On Son 07.09.2008 21:58, David wrote:
>I now have this in my nginx.conf is this what you meant ? Does this log to the
>same error_log ?
>
>    log_format  main  '$remote_addr - $remote_user [$time_local] $request '
>                      '"$status" $body_bytes_sent "$http_referer" '
>                      '"$http_user_agent" "$http_x_forwarded_for"';
>
>log_format timing '$remote_addr - $remote_user [$time_local] $request '
>                  'upstream_response_time $upstream_response_time '
>                  'msec $msec request_time $request_time';

No you need to add this line in nginxs config file and send a HUP to the
master process

access_log  logs/timing.log timing;
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-08 00:27
(Received via mailing list)
This didn't resort in a 504 but was a situation I can replicate over and
over
with the server on 0.4 load averages:

xxx.xxx.xxx.xxx - - [07/Sep/2008:17:16:54 -0500] POST
/forums/private.php?do=insertpm&pmid=101373 HTTP/1.1
upstream_response_time
37.832 msec 1220825814.697 request_time 37.833
7a7c51366e39603df74feef200a3a1c1?d=identicon&s=25 Aleksandar Lazic (Guest)
on 2008-09-08 00:42
(Received via mailing list)
On Son 07.09.2008 22:19, David wrote:

>This didn't resort in a 504 but was a situation I can replicate over
>and over with the server on 0.4 load averages:
>
>xxx.xxx.xxx.xxx - - [07/Sep/2008:17:16:54 -0500] POST
>/forums/private.php?do=insertpm&pmid=101373 HTTP/1.1
>upstream_response_time 37.832 msec 1220825814.697 request_time 37.833

Ok please can you increse the

max_execution_time = 40

to

max_execution_time = 80

add error_reporting = E_ALL

in php.ini and restart php-fm

and please can you add

$status

after

[$time_local]
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-08 00:54
(Received via mailing list)
I have done all that you asked.

Very, very, rarely that script will execute (it's just sending a private
message
to another user) as it should - basically instantly.

I see sometimes fastcgi is logging the

I have just managed to recreate the 504 error and I can see no errors in
my
php-error-log file.

The 504 occured here:

[07/Sep/2008:17:44:24 -0500] 504 POST
/forums/private.php?do=insertpm&pmid=101373 HTTP/1.1
upstream_response_time
60.000 msec 1220827464.227 request_time 60.003

and in the nginx error_log:

30104#0: *43481 upstream timed out (110: Connection timed out) while
reading
response header from upstream, client
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-08 00:58
(Received via mailing list)
I sometimes get these:

an upstream response is buffered to a temporary file
/usr/local/nginx/fastcgi_temp/0/00/0000000000 while reading upstream
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-08 09:27
(Received via mailing list)
Also getting a lot of these:

Sep 07 17:16:00.585206 [WARNING] fpm_children_bury(), line 229: child
27767
(pool default) exited on signal 15 SIGTERM after 4734.359086 seconds
Sep 07 17:16:00.585350 [WARNING] fpm_children_bury(), line 229: child
27770
(pool default) exited on signal 15 SIGTERM after 4734.355287 seconds
Sep 07 17:16:00.585452 [WARNING] fpm_children_bury(), line 229: child
27772
(pool default) exited on signal 15 SIGTERM after 4734.352343 seconds
7f006226eff37eaa07b1e8b96f521cb2?d=identicon&s=25 Kiril Angov (Guest)
on 2008-09-08 09:33
(Received via mailing list)
Try posting also to the PHP-FPM list. The author of PHP-FPM is very
well familiar with nginx and will be able to help you out here.

Kiril
7a7c51366e39603df74feef200a3a1c1?d=identicon&s=25 Aleksandar Lazic (Guest)
on 2008-09-08 11:17
(Received via mailing list)
On Mon 08.09.2008 10:24, Kiril Angov wrote:
>
>Try posting also to the PHP-FPM list. The author of PHP-FPM is very
>well familiar with nginx and will be able to help you out here.

full ack
7a7c51366e39603df74feef200a3a1c1?d=identicon&s=25 Aleksandar Lazic (Guest)
on 2008-09-08 11:20
(Received via mailing list)
On Son 07.09.2008 22:47, David wrote:
>The 504 occured here:
>
>[07/Sep/2008:17:44:24 -0500] 504 POST
>/forums/private.php?do=insertpm&pmid=101373 HTTP/1.1 upstream_response_time
>60.000 msec 1220827464.227 request_time 60.003

You see here first the 40s in php.ini and now the 60s in php-fm config
kills the process.

Please can you try to find out how long the task should run normaly!

You can try to set both values (request_execution_timeout,
max_execution_time) to a high value and see how long the task run
normally

Aleks
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-08 14:27
(Received via mailing list)
Thank you Kiril, I'll do that. I wasn't sure whether this was stricly an
nginx
or php-fpm issue, but it does sound more PHP related.
Df285f7b6e32c5458d4a60e26bb81d77?d=identicon&s=25 Chris Savery (Guest)
on 2008-09-08 16:27
(Received via mailing list)
You may want to try using spawn-fcgi just as a test to see if behaviour
changes.
Chris:)
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-08 21:22
(Received via mailing list)
Aleksander,

You mentioned about securing php.ini and referred to:

http://www.php.net/manual/en/session.configuration...
http://www.php.net/manual/en/session.configuration...

Can you please advise what these should be set to ?

Thanks
7a7c51366e39603df74feef200a3a1c1?d=identicon&s=25 Aleksandar Lazic (Guest)
on 2008-09-08 21:47
(Received via mailing list)
Dear David,

I think this is now ot. I switch to personal mail.

On Mon 08.09.2008 19:13, David wrote:
>Aleksander,
>
>You mentioned about securing php.ini and referred to:
>
>http://www.php.net/manual/en/session.configuration...
>http://www.php.net/manual/en/session.configuration...
>
>Can you please advise what these should be set to ?
6f8f7b012ce674e3781244e591f747f3?d=identicon&s=25 rkmr.em@gmail.com (Guest)
on 2008-09-08 22:43
(Received via mailing list)
hei guys
do post your final findings here on how u fixed the problems!
7a7c51366e39603df74feef200a3a1c1?d=identicon&s=25 Aleksandar Lazic (Guest)
on 2008-09-08 22:46
(Received via mailing list)
On Mon 08.09.2008 13:00, rkmr.em@gmail.com wrote:
>hei guys
>do post your final findings here on how u fixed the problems!

Yes
7904a5bf6af6f28bd15eebb484ea3a7e?d=identicon&s=25 David (Guest)
on 2008-09-09 19:35
(Received via mailing list)
Just an update ...

Whilst I feel it may be too early to say this is resolved, I have made a
lot of
progress.

Tidying up the order of my <location> sections in nginx.conf appears to
have
made the PHP execute as quickly as it should.

I'm going to give this a couple more days and will update in more detail
should
things stay as good as they are now.

Thanks again all for your help.
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.