Forum: Ferret Ferret wildcard search

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Ccd1f0cb46c306feac0ec7de125d06fc?d=identicon&s=25 Joachim S. (joschy)
on 2008-08-20 12:06
Hello community,

using ferret 0.11.5 under Win2003 Server i got the following error:

Searching: "Zürich" works fine
Searching: "Zuerich*" works fine
Searching: "Zürich*" returns 0 results

Every "Umlaut" like "üä" including a wildcard leads to zero results.

I am exporting data from an UTF8 database to a ferret index. Everything
works fine, except the shown problem. Tried also different
Ferret.locales - same result.

Thank you very much for every help,

require 'ferret'
require 'active_record'
require 'yaml'
require 'iconv'
include Ferret

class User < ActiveRecord::Base

#database with UTF8-general, search user
db_config =
user = User.find(:first, :conditions => ['uid= ?', 'jschneid'])

#create new ferret index
field_infos =

#create new ferret index
ferret_configuration = {
            :path =>
            :handle_parse_errors => true,
            :default_search_field => '*',
      :analyzer =>,
            :wild_lower => true

index =

#update index
doc =
doc['city'] =
doc['uid'] = user.uid

index << doc

#result: OK
value = "Zürich"
value = Iconv.conv('utf-8', 'ISO-8859-1', value)
puts (

#result: 0 -> error
value = "Zürich*"
value = Iconv.conv('utf-8', 'ISO-8859-1', value)
puts (
This topic is locked and can not be replied to.