Forum: Radiant CMS Comments Extension

Db6560243a4e196284cd42f413c7fc35?d=identicon&s=25 Josh Schairbaum (Guest)
on 2008-07-14 13:00
(Received via mailing list)
I've just installed the Comments Extension into a new Radiant
application.  It appears to work, except that every request I make
adds an additional link to 'enable' comments on the page listing
page.  After 15 requests, there's 15 links.  Restarting the server
corrects this.

Where can I find where the extension adds the overlay to the admin
pages?

Regards,
Josh
09477c358c5897d44121a248326e16d7?d=identicon&s=25 Jim Gay (Guest)
on 2008-07-14 13:13
(Received via mailing list)
This is a bug in 0.6.7 that occurs when run in development mode. If
you run it in production mode it will go away, or if you freeze to the
edge that should also take care of it.
Db6560243a4e196284cd42f413c7fc35?d=identicon&s=25 Josh Schairbaum (Guest)
on 2008-07-14 13:18
(Received via mailing list)
Embarrassing for me.  I've subscribed to this mailing list for several
months now and seen people talk about this known bug, but never read
them since I didn't have an issue.  Lesson learned by me, then.

Thanks Jim.

Regards,
Josh
491892349b82ad4e00d71eb844768147?d=identicon&s=25 Steven Southard (Guest)
on 2009-03-03 01:03
(Received via mailing list)
What did happen when you submitted the comment?  Did you get an error?
Typical, it will show your comment and say that it's awaiting
approval.  In the comments tab in the admin you can then see and
approve the comment.  In your case it's a little unclear what you did
or what results you got.
E73aea688189f4ad347b826c22ea2026?d=identicon&s=25 Bryce Klimoski (Guest)
on 2009-03-03 09:23
(Received via mailing list)
There is no error and it does not show up in the comments tab waiting
for approval.  When I clicked on save comment my browser pulls up me
http://localhost:3000/comments, however since I have not added any
content to that page it comes up blank.  I'm guessing there is
something that needs to be added there. I have also look in the
comments table which is blank.

On Sun, Mar 1, 2009 at 11:00 PM, Steven Southard
Ec797ac7978ab39f04b0a5844c234528?d=identicon&s=25 Mohit Sindhwani (mohits)
on 2009-03-03 10:26
(Received via mailing list)
Bryce Klimoski wrote:
> There is no error and it does not show up in the comments tab waiting
> for approval.  When I clicked on save comment my browser pulls up me
> http://localhost:3000/comments, however since I have not added any
> content to that page it comes up blank.  I'm guessing there is
> something that needs to be added there. I have also look in the
> comments table which is blank.
>
>
HI I'm sorry I can't directly help with your problem here, but just to
be clear, did you follow the instructions about using the Comments
extension as given in the wiki page about using Radiant as a blog?
http://wiki.radiantcms.org/Using_Radiant_as_a_Blog

Cheers,
Mohit.
3/3/2009 | 12:23 AM.
E73aea688189f4ad347b826c22ea2026?d=identicon&s=25 Bryce Klimoski (Guest)
on 2009-03-03 11:18
(Received via mailing list)
Thanks for the link I'll take a closer look at it when I get home from
work.
Ec797ac7978ab39f04b0a5844c234528?d=identicon&s=25 Mohit Sindhwani (mohits)
on 2009-03-03 11:46
(Received via mailing list)
Bryce Klimoski wrote:
> following problem(s).
> with a 404 error for /comments.  So I created that page and repeated
> my test.  Page came up fine, however the comment did not save in the
> database.  What am I missing here?  Is there a tag I need to add the
> /comments page for it to save them?
>
Hi Bryce

Did you run the migration?

Cheers,
Mohit.
3/3/2009 | 1:43 AM.
E73aea688189f4ad347b826c22ea2026?d=identicon&s=25 Bryce Klimoski (Guest)
on 2009-03-03 19:41
(Received via mailing list)
I ran both the update and migrate tasks..

rake radiant:extensions:comments:update
rake radiant:extensions:comments:migrate

I did not see an error occur with either one of them.

I also took a look at the url you sent earlier
http://wiki.radiantcms.org/Using_Radiant_as_a_Blog and the only thing I
have
not done is enable Akismet, which I understand to be optional (I will be
doing once I get into production).

Thanks,
Bryce
E73aea688189f4ad347b826c22ea2026?d=identicon&s=25 Bryce Klimoski (Guest)
on 2009-03-03 23:33
(Received via mailing list)
After looking at the code I figured out what I was doing wrong and got
it
working.  It seems the Comments Extension does not like it when you
attempt
to post comments from the home page of the site.

I do have one small question is there a way for me to skip the approval
process?  I'd rather they just be approved.  I suppose I can edit the
extension, however I was just hopping that was not necessary.

Thanks,
Bryce
E8d27b9246051fff88e348844afd57ce?d=identicon&s=25 Bartee Lamar (bartee)
on 2009-04-13 02:59
Bryce Klimoski wrote:
> After looking at the code I figured out what I was doing wrong and got
> it
> working.  It seems the Comments Extension does not like it when you
> attempt
> to post comments from the home page of the site.
>
> I do have one small question is there a way for me to skip the approval
> process?  I'd rather they just be approved.  I suppose I can edit the
> extension, however I was just hopping that was not necessary.
>
> Thanks,
> Bryce

I think using Akismet will automatically approve the comment.
09477c358c5897d44121a248326e16d7?d=identicon&s=25 Jim Gay (Guest)
on 2009-05-15 15:33
(Received via mailing list)
This is a bug in the extension.
It submits comments to the_page_url/comments and sets up routes to
catch that and send it to the comments controller.
We'll need to make an exception for the home page and perhaps create a
custom route for it.

Are you really accepting comments on your home page, or are you
accepting comments on content listed on the homepage but actually
saved in another location? It's possible that you might need to alter
your radius code if that is the case.

On May 14, 2009, at 4:18 PM, Rafael Souza wrote:

> Anyone know how I fix it?
>
> Thanks

Jim Gay
http://www.saturnflyer.com
6bed9a8f9c823d56f34b67ef6f64db98?d=identicon&s=25 Rafael Souza (Guest)
on 2009-05-15 16:18
(Received via mailing list)
The home comments was only for test, the blog comments works fine now!
=]

One more doubt, how can I turn the comments moderated? For show in page
only
after approved?

Thanks Jim, helped me a lot!
6bed9a8f9c823d56f34b67ef6f64db98?d=identicon&s=25 Rafael Souza (Guest)
on 2009-05-15 17:24
(Received via mailing list)
I saw the code and I think that, to make the comments unapproved for
default, the way is to comment the line seven of comment.rb model:
"#before_save :auto_approve"

Can someone tells me if this is the best way?

Thanks,

Rafael Souza
E8d27b9246051fff88e348844afd57ce?d=identicon&s=25 Bartee Lamar (bartee)
on 2009-06-04 03:10
Here is the hack I put in to bypass approvals...

in comments_controller.rb

In the def create

add this line..

comment.approved_at = Time.now

it creates the comment with a time stamp, which indicates approval.

I get a deep error when I try to us mollom...

I would like to use it, but my customer is screaming that they have to
have these comments working..

Radiant Comments automatic approval
This topic is locked and can not be replied to.