Forum: Rails Engines How to set logging level for Rails Engines

A4f2431f4527120eec207fab4edf1530?d=identicon&s=25 Franck Yu (franck33)
on 2008-05-05 09:40
Hello,

I get "Checking plugin..." all the time in the log and would like to
disable it. I figure out that it comes from Engines.logger and want to
set the logging level to info in stead of debug. How can I do this?
Thaks!


Franck
E92fcc3eb8b64be02c61360497066311?d=identicon&s=25 Chris Lee (cglee)
on 2008-07-29 00:28
To minimize engines polluting our logs, we just changed the logger for
the engines plugin like this:

In engines.rb, update the logger method:

    def logger
      #RAILS_DEFAULT_LOGGER
      Logger.new(RAILS_ROOT + "/log/engines.log")
    end

And then create an "engines.log" under your /log directory.  Now all
engines related logging will be directed to that file instead of your
development.log.
E92fcc3eb8b64be02c61360497066311?d=identicon&s=25 Chris Lee (cglee)
on 2008-07-29 01:01
Probably better to do this:

  Logger.new(File.join(RAILS_ROOT, "log", "engines.log"))
1ac774797c9e79861840599b23653c3c?d=identicon&s=25 Wins Lin (zvooq)
on 2013-06-14 10:05
Chris Lee wrote in post #708133:
> In engines.rb, update the logger method:
>
>     def logger
>       #RAILS_DEFAULT_LOGGER
>       Logger.new(RAILS_ROOT + "/log/engines.log")
>     end

But how to use it then? Wouldn't it instantiate a new Logger instance
every
time I call it?

def some_foo_method
  # I want to log something, I call the logger method
  logger.debug("I did something")
end

So, the "logger" method instantiates a new Logger instance every time.
It is not good to have dozens logger instances in memory. How to avoid
it? How to instantiate once and then just take only that one instance?
728dc775293a7deb16919a7596ab3420?d=identicon&s=25 Tap Chi (tapchi18plus)
on 2014-05-18 19:07
I get "Checking plugin..." all the time in the log and would like to
disable it. I figure out that it comes from Engines.logger and want to
set the logging level to info in stead of debug. How can I do this?
Thaks!
This topic is locked and can not be replied to.