Forum: Ruby-Forum.com Arrrg!!! Load Error : Expected.../forum.rb to define forum

777f61e53403bd9b8b8d1445a672bc2c?d=identicon&s=25 Tiffany Sonny (tsonnysys)
on 2007-12-20 12:57
I keep getting the following error when I deploy to mongrel:

Expected C:/muforum/rforum/app/models/forum.rb to define Forum
RAILS_ROOT: C:/muforum/rforum

Application Trace | Framework Trace | Full Trace
C:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.0.1/lib/active_support/dependencies.rb:249:in
`load_missing_constant'
C:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.0.1/lib/active_support/dependencies.rb:453:in
`const_missing'
C:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.0.1/lib/active_support/dependencies.rb:465:in
`const_missing'
C:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.0.1/lib/active_support/dependencies.rb:471:in
`send'
C:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.0.1/lib/active_support/dependencies.rb:471:in
`const_missing' app/controllers/application.rb:148:in
`get_forums'-e:2:in `load'-e:2

Has anyone experienced this while setting up the project?

I have tried freezing my rails version and reviewed the log file.

I am up all night on this one problem and pressed to complete the work.

T.Sonny
777f61e53403bd9b8b8d1445a672bc2c?d=identicon&s=25 Tiffany Sonny (tsonnysys)
on 2007-12-20 22:09


I resolved this issue by correcting my Rails version to 1.2.3
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.