Forum: Ruby on Rails require & dependency problems switching to 0.14.2

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
kianwright (Guest)
on 2005-11-12 12:49
(Received via mailing list)
Hello,

Just switched from 0.13 to 0.14.2, and all the sudden I'm getting tons
of errors relating to
dependencies not being automatically figured out. Lots of uninitialized
constant errors. Mostly
related to model files -- seems like Rails can no longer figure out how
to automatically load a
referenced model file. I have to explicitly 'require' them to get it to
work.

I'm sure that's not the only place I have problems. But the app is so
broken now, it's hard to
investigate further. :-(

Unfortunately, this also coincides with a switch of hosts, so that may
be the source of the
problems too... how can I tell? Environment files are all the same.

Any ideas?
jeremy (Guest)
on 2005-11-12 12:49
(Received via mailing list)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Nov 8, 2005, at 8:58 PM, Kian Wright wrote:
> so broken now, it's hard to
> investigate further. :-(
>
> Unfortunately, this also coincides with a switch of hosts, so that
> may be the source of the
> problems too... how can I tell? Environment files are all the same.

Did you upgrade your application as well?

See http://manuals.rubyonrails.org/read/chapter/121

jeremy
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (Darwin)

iD8DBQFDcYo/AQHALep9HFYRArbOAKDNC+/u1cc6zsj+1irS/DVly+vEiwCfcKGo
hmDuijT51OCwqwtuXQhdIvY=
=LBw1
-----END PGP SIGNATURE-----
This topic is locked and can not be replied to.