Forum: Radiant CMS Page_attachments multi-part form issue

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Bdf2290f0b1d87cb0853966e7e51606b?d=identicon&s=25 Andrew O'Brien (Guest)
on 2007-08-02 23:24
(Received via mailing list)
First off, preemptive apology in case this is a repeat of another bug
report with page_attachments (I did search the archives, so I think
this is a new one)...

Whenever I try to both upload a file and make a change to a standard
page_part, I get the error below.  If I just upload an image, or just
change the text field, everything works fine.  Also, I can click Save
& Continue Editing.  My setup is:

Browser: Safari 3.0.3 Beta
Radiant: Completely clean install of Edge Radiant checked out today
with only the page_attachment extension.

Interestingly enough, it seems to work fine in Firefox.  Looking
through the trace, my feeling is this might be a Safari 3 Beta
problem, since I actually don't see any of the extension's code
getting called.  Any idea what might be causing this?  Anybody able to
replicate?

Thanks,
Andrew

Thu Aug 02 16:55:00 EDT 2007: Error calling Dispatcher.dispatch
#<EOFError: bad content body>
/usr/local/lib/ruby/gems/1.8/gems/cgi_multipart_eof_fix-1.0.0/lib/cgi_multipart_eof_fix.rb:60:in
`read_multipart'
/usr/local/lib/ruby/gems/1.8/gems/cgi_multipart_eof_fix-1.0.0/lib/cgi_multipart_eof_fix.rb:23:in
`read_multipart'
./script/../config/../vendor/radiant/vendor/rails/actionpack/lib/action_controller/cgi_ext/raw_post_data_fix.rb:38:in
`initialize_query'
/usr/local/lib/ruby/1.8/cgi.rb:2270:in `initialize'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.18/lib/mongrel/cgi.rb:50:in
`initialize'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.18/lib/mongrel/rails.rb:69:in
`process'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.18/lib/mongrel.rb:587:in
`process_client'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.18/lib/mongrel.rb:586:in
`process_client'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.18/lib/mongrel.rb:700:in
`run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.18/lib/mongrel.rb:700:in
`run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.18/lib/mongrel.rb:687:in
`run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.18/lib/mongrel/configurator.rb:271:in
`run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.18/lib/mongrel/configurator.rb:270:in
`run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.18/bin/mongrel_rails:125:in
`run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.18/lib/mongrel/command.rb:211:in
`run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.18/bin/mongrel_rails:235
./script/../config/../vendor/radiant/vendor/rails/activesupport/lib/active_support/dependencies.rb:488:in
`load'
./script/../config/../vendor/radiant/vendor/rails/activesupport/lib/active_support/dependencies.rb:342:in
`new_constants_in'
./script/../config/../vendor/radiant/vendor/rails/activesupport/lib/active_support/dependencies.rb:488:in
`load'
./script/../config/../vendor/radiant/vendor/rails/railties/lib/commands/servers/mongrel.rb:60
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
./script/../config/../vendor/radiant/vendor/rails/activesupport/lib/active_support/dependencies.rb:495:in
`require'
./script/../config/../vendor/radiant/vendor/rails/activesupport/lib/active_support/dependencies.rb:342:in
`new_constants_in'
./script/../config/../vendor/radiant/vendor/rails/activesupport/lib/active_support/dependencies.rb:495:in
`require'
./script/../config/../vendor/radiant/vendor/rails/railties/lib/commands/server.rb:39
script/server:3
This topic is locked and can not be replied to.