Forum: Ruby on Rails Problem regarding Sybase configuration with Aptana IDE

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
44c5439ac2b4aa5c686a11020ee979e1?d=identicon&s=25 vabb_z (Guest)
on 2007-07-31 18:16
(Received via mailing list)
Hi!!,,
     I am using Apatana IDE for Rails development. I have installed
SQL explorer plugin and connected to "Sybase"database. But through
database.yml I am not able to connect to server.
In fact it gives error while running WEBrick server.

Error is like this :------>
[code]
3109
=> Booting WEBrick...
/usr/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/
connection_adapters/abstract/connection_specification.rb:210:in
`establish_connection': database configuration specifies nonexistent
sybase adapter (ActiveRecord::AdapterNotFound)
  from /usr/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/
active_record/connection_adapters/abstract/connection_specification.rb:
202:in `establish_connection'
  from /usr/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/
active_record/connection_adapters/abstract/connection_specification.rb:
195:in `establish_connection'
  from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:
229:in `initialize_database'
  from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:88:in
`process'
  from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:43:in
`send'
  from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb:43:in
`run'
  from ./script/../config/../config/environment.rb:13
  from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
   ... 12 levels...
  from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
  from ./script/server:3
  from -e:4:in `load'
  from -e:4[/code]


And mine database.yml file is ---------->

[code]

# MySQL (default setup).  Versions 4.1 and 5.0 are recommended.
#
# Install the MySQL driver:
#   gem install mysql
# On MacOS X:
#   gem install mysql -- --include=/usr/local/lib
# On Windows:
#   gem install mysql
#       Choose the win32 build.
#       Install MySQL and put its /bin directory on your path.
#
# And be sure to use new-style password hashing:
#   http://dev.mysql.com/doc/refman/5.0/en/old-client.html
development:
  adapter:   sybase
  database:  griffin
  host:      192.168.0.13
  port:      5006
  username:  sa
  password:
  numconvert: true

#  adapter: mysql
#  database: depot_development
#  host: 192.168.0.180
#  port: 3306
#  username: root
#  password:
#  socket: /tmp/mysql.sock

# Warning: The database defined as 'test' will be erased and
# re-generated from your development database when you run 'rake'.
# Do not set this db to the same as development or production.
test:
  adapter: mysql
  database: griffin_test
  username: root
  password:
  socket: /tmp/mysql.sock

production:
  adapter: mysql
  database: griffin_production
  username: root
  password:
  socket: /tmp/mysql.sock[code]
90beb7adc5c234f38a3992a7825fa64a?d=identicon&s=25 hiroysato@gmail.com (Guest)
on 2007-08-05 09:58
(Received via mailing list)
Maybe useful the following info.

http://wiki.rubyonrails.org/rails/pages/HowToSetup...

development:
   adapter:  sybase
   database:  griffin
   host:      192.168.0.13
   port:      5006
   username:  sa
   password:
   numconvert: true

no need port field.
you have to write server name which wrote in interfaces file on host
field.

like this .

interfaces file ($SYBASE/interfaces)

SYBASE_RAILS
        master tcp ether localhost 5000
        query tcp ether localhost 5000

development:
   adapter:  sybase
   database:  griffin
   host:      SYBASE_RAILS
   username:  sa
   password: sa_pass
   numconvert: true


-- hiro
This topic is locked and can not be replied to.