Forum: Ruby Need help to install FileMagic on Ubuntu Fiesty

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
41c597a48c80e37ba68d1adc7095ea0e?d=identicon&s=25 Sam Smoot (Guest)
on 2007-07-28 23:31
(Received via mailing list)
I'm trying to install FileMagic on Ubuntu. I've done this a number of
times on OS X (swapping out apt-get for macports) like so:

$ apt-get install file
$ curl -O
$ tar -xzf ruby-filemagic-0.1.1.tar.gz
$ cd ruby-filemagic-0.1.1.tar.gz
$ ruby extconf.rb

Then make & make install. I can't seem to manage on Ubuntu though. The
error I'm getting during extconf is:

checking for magic_open() in -lmagic... no
***  ERROR: missing required library to compile this module
*** extconf.rb failed ***

Can anyone help?
This topic is locked and can not be replied to.