Forum: Ruby OCI.dll was not found error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
F948f711c9596cc872a66e158d67cfc0?d=identicon&s=25 Maung Aung (maung)
on 2007-07-27 20:08
Hi all,

While I was trying to run a ruby file, I got the following error message
box:
ruby.exe - unable to locate component
This application has failed to start because oci.dll was not found.
Re-installing the application may fix this problem.

I have installed oci8 correctly and have tried uninstalled and
re-installed ruby and oci8 many times, but it didn't solve the problem.
I also found oci.dll file in my oracle directory C:\oracle\ora92\bin.
Where and what am I missing? Could someone help me out?

Thanks,
maung
8c98ddcf14eb09737e73ab629abf48e4?d=identicon&s=25 Yusuf Celik (yusufcelik)
on 2007-07-28 22:39
Hi Maung,

I'm not a ruby expert
but this problem doesn't look like a ruby error.
All I can suggest make sure the directory where oci.dll resides is in
the path.

Hope it helps
Yusuf

Maung Aung wrote:
> Hi all,
>
> While I was trying to run a ruby file, I got the following error message
> box:
> ruby.exe - unable to locate component
> This application has failed to start because oci.dll was not found.
> Re-installing the application may fix this problem.
>
> I have installed oci8 correctly and have tried uninstalled and
> re-installed ruby and oci8 many times, but it didn't solve the problem.
> I also found oci.dll file in my oracle directory C:\oracle\ora92\bin.
> Where and what am I missing? Could someone help me out?
>
> Thanks,
> maung
This topic is locked and can not be replied to.