Forum: Ferret Mongrel won't start

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
F6117797cc36023b1496349309b2df94?d=identicon&s=25 Rick Lacharite (ricklach)
on 2007-07-27 06:56
I have a win xp box running instant rails.  I installed ferret (the win
version) and acts_as_ferret seemingly succesfully. I then added "require
'acts_as_ferret'" to the environment.rb file of my project.  However, I
cannot get webrick/mongrel to start.  Can anyone suggest a solution?

Rick
C9dd93aa135988cabf9183d3210665ca?d=identicon&s=25 Jens Kraemer (Guest)
on 2007-07-27 10:14
(Received via mailing list)
On Fri, Jul 27, 2007 at 06:56:34AM +0200, Rick Lacharite wrote:
> I have a win xp box running instant rails.  I installed ferret (the win
> version) and acts_as_ferret seemingly succesfully. I then added "require
> 'acts_as_ferret'" to the environment.rb file of my project.  However, I
> cannot get webrick/mongrel to start.  Can anyone suggest a solution?

Hardly without any further info.

Did you install aaf as a plugin or via ruby gems? the require is not
needed if aaf resides in vendor/plugins inside your application.

Jens

--
Jens Krämer
webit! Gesellschaft für neue Medien mbH
Schnorrstraße 76 | 01069 Dresden
Telefon +49 351 46766-0 | Telefax +49 351 46766-66
kraemer@webit.de | www.webit.de

Amtsgericht Dresden | HRB 15422
GF Sven Haubold, Hagen Malessa
F6117797cc36023b1496349309b2df94?d=identicon&s=25 Rick Lacharite (ricklach)
on 2007-07-28 01:38
Jens Kraemer wrote:
> On Fri, Jul 27, 2007 at 06:56:34AM +0200, Rick Lacharite wrote:
>> I have a win xp box running instant rails.  I installed ferret (the win
>> version) and acts_as_ferret seemingly succesfully. I then added "require
>> 'acts_as_ferret'" to the environment.rb file of my project.  However, I
>> cannot get webrick/mongrel to start.  Can anyone suggest a solution?
>
> Hardly without any further info.
>
> Did you install aaf as a plugin or via ruby gems? the require is not
> needed if aaf resides in vendor/plugins inside your application.
>
> Jens
>
> --
> Jens Kr�mer
> webit! Gesellschaft f�r neue Medien mbH
> Schnorrstra�e 76 | 01069 Dresden
> Telefon +49 351 46766-0 | Telefax +49 351 46766-66
> kraemer@webit.de | www.webit.de
>
> Amtsgericht Dresden | HRB 15422
> GF Sven Haubold, Hagen Malessa

Jens,

I installed aaf as a gem.  I couldn't get the plugin to install.

Rick
F6117797cc36023b1496349309b2df94?d=identicon&s=25 Rick Lacharite (ricklach)
on 2007-07-28 01:44
Rick Lacharite wrote:
> Jens Kraemer wrote:
>> On Fri, Jul 27, 2007 at 06:56:34AM +0200, Rick Lacharite wrote:
>>> I have a win xp box running instant rails.  I installed ferret (the win
>>> version) and acts_as_ferret seemingly succesfully. I then added "require
>>> 'acts_as_ferret'" to the environment.rb file of my project.  However, I
>>> cannot get webrick/mongrel to start.  Can anyone suggest a solution?
>>
>> Hardly without any further info.
>>
>> Did you install aaf as a plugin or via ruby gems? the require is not
>> needed if aaf resides in vendor/plugins inside your application.
>>
>> Jens
>>
>> --
>> Jens Kr�mer
>> webit! Gesellschaft f�r neue Medien mbH
>> Schnorrstra�e 76 | 01069 Dresden
>> Telefon +49 351 46766-0 | Telefax +49 351 46766-66
>> kraemer@webit.de | www.webit.de
>>
>> Amtsgericht Dresden | HRB 15422
>> GF Sven Haubold, Hagen Malessa
>
 Jens,

 I installed aaf as a gem.  I couldn't get the plugin to install.  This
was the output when I tried to start webrick"

G:\emporium>ruby script/server
=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment...
Exiting
G:/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/servers/mon
grel.rb:15: warning: already initialized constant OPTIONS
G:/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/servers/mon
grel.rb:18: undefined method `options' for []:Array (NoMethodError)
        from
G:/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require
.rb:32:in `gem_original_require'
        from
G:/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require
.rb:32:in `require'
        from
G:/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib
/active_support/dependencies.rb:495:in `require'
        from
G:/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib
/active_support/dependencies.rb:342:in `new_constants_in'
        from
G:/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib
/active_support/dependencies.rb:495:in `require'
        from
G:/InstantRails/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/command
s/server.rb:39
        from
G:/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require
.rb:27:in `gem_original_require'
        from
G:/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require
.rb:27:in `require'
        from script/server:3
6ba611bd72eed6ebf92e6124454f879a?d=identicon&s=25 Cass Amino (myowntribe)
on 2007-07-28 07:48
Rick Lacharite wrote:
> I have a win xp box running instant rails.  I installed ferret (the win
> version) and acts_as_ferret seemingly succesfully. I then added "require
> 'acts_as_ferret'" to the environment.rb file of my project.  However, I
> cannot get webrick/mongrel to start.  Can anyone suggest a solution?
>
> Rick

Hi Rick

I had the same problem but after I reinstalled ferret with 'gem install
ferret'  command, mongrel started normally.

If you havent installed ferret do this:

gem install ferret

and then start the server, it might work.

And if you have installed acts_as_ferret locally in your project in the
vendor/plugin directory you need not have to type 'require
acts_as_ferret' in environment.rb

Cheers

Cass
F6117797cc36023b1496349309b2df94?d=identicon&s=25 Rick Lacharite (ricklach)
on 2007-07-28 18:27
Cass Amino wrote:
> Rick Lacharite wrote:
>> I have a win xp box running instant rails.  I installed ferret (the win
>> version) and acts_as_ferret seemingly succesfully. I then added "require
>> 'acts_as_ferret'" to the environment.rb file of my project.  However, I
>> cannot get webrick/mongrel to start.  Can anyone suggest a solution?
>>
>> Rick
>
> Hi Rick
>
> I had the same problem but after I reinstalled ferret with 'gem install
> ferret'  command, mongrel started normally.
>
> If you havent installed ferret do this:
>
> gem install ferret
>
> and then start the server, it might work.
>
> And if you have installed acts_as_ferret locally in your project in the
> vendor/plugin directory you need not have to type 'require
> acts_as_ferret' in environment.rb
>
> Cheers
>
> Cass

Thanks Cass,

That seems to have worked.  I need to do some testing to check it out
completely.

Rick
This topic is locked and can not be replied to.