Forum: Ruby Strange error installing RubyGems

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
05e4e83c87a5700958fcb3efa8951a06?d=identicon&s=25 vasudevram (Guest)
on 2007-07-25 19:05
(Received via mailing list)
Hi,

I'm on Windows 2000 with Service Pack 4.
Was installing RubyGems and got the error shown below - at the end of
this post.

Tried it a few times (including uninstalling my complete Ruby
installation, in case some files had got messed up), but got the same
error each time. The main or only error is at the end of the output,
but I've shown the full output below. It says:

  Successfully built RubyGem

but then says:

hook C:/Temp/inst/rubygems-0.9.4/./post-install.rb failed:
install directory #<Pathname:C:/ruby184-20/lib/ruby/gems/1.8/gems/
sources-0.0.1>
 not absolute

Would appreciate any pointers to what the errors might be due to.
Interestingly, this the first time this has happened. I've been
programming Ruby for some time now, and have never had a problem
installing either Ruby itself, or RubyGems, earlier.
This error happened after I had uninstalled my earlier Ruby version
and was installing the latest stable Ruby version, and then the latest
stable RubyGem version.
----------

Errors while running "ruby setup.rb" (also tried "ruby setup.rb all")
to install RubyGems v0.9.4:
[ The error is at the end of the output below - at and below this
line:
"hook C:/Temp/inst/rubygems-0.9.4/./post-install.rb failed:"
]

C:\Temp\inst\rubygems-0.9.4>ruby setup.rb all
---> bin
<--- bin
---> lib
---> lib/rbconfig
<--- lib/rbconfig
---> lib/rubygems
---> lib/rubygems/commands
<--- lib/rubygems/commands
---> lib/rubygems/digest
<--- lib/rubygems/digest
<--- lib/rubygems
<--- lib
---> bin
<--- bin
---> lib
---> lib/rbconfig
<--- lib/rbconfig
---> lib/rubygems
---> lib/rubygems/commands
<--- lib/rubygems/commands
---> lib/rubygems/digest
<--- lib/rubygems/digest
<--- lib/rubygems
<--- lib
rm -f InstalledFiles
---> bin
mkdir -p C:/ruby184-20/bin/
install gem C:/ruby184-20/bin/
install gem_mirror C:/ruby184-20/bin/
install gem_server C:/ruby184-20/bin/
install gemlock C:/ruby184-20/bin/
install gemri C:/ruby184-20/bin/
install gemwhich C:/ruby184-20/bin/
install index_gem_repository.rb C:/ruby184-20/bin/
install update_rubygems C:/ruby184-20/bin/
<--- bin
---> lib
mkdir -p C:/ruby184-20/lib/ruby/site_ruby/1.8/
install gemconfigure.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
install rubygems.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
install ubygems.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
---> lib/rbconfig
mkdir -p C:/ruby184-20/lib/ruby/site_ruby/1.8/rbconfig
install datadir.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rbconfig
<--- lib/rbconfig
---> lib/rubygems
mkdir -p C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install builder.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install command_manager.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems
install config_file.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install custom_require.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems
install dependency_list.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems
install doc_manager.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install format.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install gem_commands.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install gem_open_uri.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install gem_openssl.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install gem_runner.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install installer.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install old_format.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install open-uri.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install package.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install remote_fetcher.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems
install remote_installer.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems
install rubygems_version.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems
install security.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install server.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install source_index.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install source_info_cache.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems
install source_info_cache_entry.rb C:/ruby184-20/lib/ruby/site_ruby/
1.8/rubygems

install specification.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install timer.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install user_interaction.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems
install validator.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
install version.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems
---> lib/rubygems/commands
mkdir -p C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems/commands
install build_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems/
commands
install cert_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems/
commands
install check_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems/
commands
install cleanup_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/command
s
install contents_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/comman
ds
install dependency_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/comm
ands
install environment_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/com
mands
install help_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems/
commands
install install_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/command
s
install list_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems/
commands
install outdated_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/comman
ds
install pristine_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/comman
ds
install query_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems/
commands
install rdoc_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems/
commands
install search_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/commands

install sources_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/command
s
install specification_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/c
ommands
install uninstall_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/comma
nds
install unpack_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/commands

install update_command.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/commands

<--- lib/rubygems/commands
---> lib/rubygems/digest
mkdir -p C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems/digest
install digest_adapter.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/
rubygems/digest
install md5.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems/digest
install sha1.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems/digest
install sha2.rb C:/ruby184-20/lib/ruby/site_ruby/1.8/rubygems/digest
<--- lib/rubygems/digest
<--- lib/rubygems
<--- lib
  Successfully built RubyGem
  Name: sources
  Version: 0.0.1
  File: sources-0.0.1.gem
hook C:/Temp/inst/rubygems-0.9.4/./post-install.rb failed:
install directory #<Pathname:C:/ruby184-20/lib/ruby/gems/1.8/gems/
sources-0.0.1>
 not absolute
Try 'ruby setup.rb --help' for detailed usage.


Thanks
Vasudev Ram
http://www.dancingbison.com
http://jugad.livejournal.com
http://sourceforge.net/projects/xtopdf
This topic is locked and can not be replied to.