Forum: Ruby on Rails NoMethodError in action_view/helpers/form_helper.rb:302:in `

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Cca830c7301cfc8b87edf8eb6da20a9c?d=identicon&s=25 al schmid (Guest)
on 2007-07-22 23:23
(Received via mailing list)
Hello everyone

I have this rather strange problem. After updating rails from 1.1.6 to
1.2.2 I get these errors when using check_box and radio_button. Before
everything was peachy...
System: OS X (10.4.10), MySQL, Ruby 1.8.5, Rails 1.2.2

This is the line that seems to offend:

13: <p><%= check_box("tour", "is_festival") %><label
for="tour_bezeichnung">Ist ein Festival (der Festivalname wird
anstelle der Bands benutzt)</label>

The object, a CalendarTour (in @tour) is an object extended from
ActiveRecord::Base.

The error report at the bottom reads as follows:

#{RAILS_ROOT}/vendor/rails/actionpack/lib/action_view/helpers/
form_helper.rb:302:in `value'
#{RAILS_ROOT}/vendor/rails/actionpack/lib/action_view/helpers/
form_helper.rb:302:in `to_check_box_tag'
#{RAILS_ROOT}/vendor/rails/actionpack/lib/action_view/helpers/
form_helper.rb:210:in `check_box'
#{RAILS_ROOT}/app/views/resys/calendar/enter_tourdates.rhtml:13:in
`_run_rhtml_47app47views47resys47calendar47enter_tourdates46rhtml'
#{RAILS_ROOT}/app/controllers/resys/calendar_controller.rb:411:in
`save_tourdates'

I can't for the life of me find what's wrong. I get these random
seeming errors in different FORMs...

Any ideas? Thanks a lot!
al
8ec3fe4f1729b3c07e3ea19421e6b646?d=identicon&s=25 unknown (Guest)
on 2007-07-27 19:05
(Received via mailing list)
I was able to fix this same problem by replacing my boot.rb and
environment.rb files in my old 1.1.6 app with the same files from a
freshly-generated 1.2.3 app. Still not sure what specifically caused
it, but I suspect it's something with the gem code in the boot.rb
file.
Cca830c7301cfc8b87edf8eb6da20a9c?d=identicon&s=25 al schmid (Guest)
on 2007-07-28 17:03
(Received via mailing list)
Seems like that took care of it. Very strange indeed. But thanks a
lot!
al
Cca830c7301cfc8b87edf8eb6da20a9c?d=identicon&s=25 al schmid (Guest)
on 2007-07-30 20:35
(Received via mailing list)
Ooops, I was too fast there...
Went from lighttpd to mongrel...
Now Rails tells me (via NoMethodError) that my "Artist" class has lost
the method "quoted_id" which is derived from ActiveRecords as far as I
can see...
BUT: The funny thing is: If I call that one page (a FORM post) right
after I restarted mongrel, it works. If I enter the data into the form
again and then post the form, boom, the NoMethodError strikes. This is
driving me nuts...

Tried changing the environment.rb / boot.rb again, was no use...

Any ideas anyone?
Thanks!
al
This topic is locked and can not be replied to.