Forum: Rails-ES Rail con apt-get y problemas con las gemas

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
9b3b1fd6baa8379638d8399ecd60045d?d=identicon&s=25 Emili Parreño (emili)
on 2007-07-20 17:59
Buenas, he instalado rails con apt-get (version 1.2.2) el probema es que
cuando intento instalar una gema con rubygems me aparece el siguiente
error

# gem install hoe
Successfully installed hoe-1.2.1
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require': no such file to load -- rdoc/rdoc (LoadError)
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /usr/local/lib/site_ruby/1.8/rubygems/doc_manager.rb:71:in
`load_rdoc'
        from /usr/local/lib/site_ruby/1.8/rubygems/doc_manager.rb:41:in
`generate_ri'
        from
/usr/local/lib/site_ruby/1.8/rubygems/commands/install_command.rb:112:in
`execute'
        from
/usr/local/lib/site_ruby/1.8/rubygems/commands/install_command.rb:111:in
`each'
        from
/usr/local/lib/site_ruby/1.8/rubygems/commands/install_command.rb:111:in
`execute'
        from
/usr/local/lib/site_ruby/1.8/rubygems/commands/install_command.rb:49:in
`each'
        from
/usr/local/lib/site_ruby/1.8/rubygems/commands/install_command.rb:49:in
`execute'
        from /usr/local/lib/site_ruby/1.8/rubygems/command.rb:70:in
`invoke'
        from
/usr/local/lib/site_ruby/1.8/rubygems/command_manager.rb:121:in
`process_args'
        from
/usr/local/lib/site_ruby/1.8/rubygems/command_manager.rb:92:in `run'
        from /usr/local/lib/site_ruby/1.8/rubygems/gem_runner.rb:30:in
`run'
        from /usr/bin/gem:23


Alguna idee?
373c4dd765755059d502b2077c1722b9?d=identicon&s=25 Emilio Tagua (Guest)
on 2007-07-20 18:10
(Received via mailing list)
On 7/20/07, Emili Parreño <ruby-forum-incoming@andreas-s.net> wrote:
>         from /usr/local/lib/site_ruby/1.8/rubygems/doc_manager.rb:71:in
> /usr/local/lib/site_ruby/1.8/rubygems/commands/install_command.rb:111:in
> /usr/local/lib/site_ruby/1.8/rubygems/command_manager.rb:121:in
> `process_args'
>         from
> /usr/local/lib/site_ruby/1.8/rubygems/command_manager.rb:92:in `run'
>         from /usr/local/lib/site_ruby/1.8/rubygems/gem_runner.rb:30:in
> `run'
>         from /usr/bin/gem:23
>
>
> Alguna idee?

$sudo apt-get remove rails --purge

$sudo gem i rails --include-dependencies


Saludos!
9b3b1fd6baa8379638d8399ecd60045d?d=identicon&s=25 Emili Parreño (emili)
on 2007-07-20 18:16
Eso ya lo sé, pero nu puedo hacerlo. Necesito Rails como paquete de
debian.

Emilio Tagua wrote:
> On 7/20/07, Emili Parre�o <ruby-forum-incoming@andreas-s.net> wrote:
>>         from /usr/local/lib/site_ruby/1.8/rubygems/doc_manager.rb:71:in
>> /usr/local/lib/site_ruby/1.8/rubygems/commands/install_command.rb:111:in
>> /usr/local/lib/site_ruby/1.8/rubygems/command_manager.rb:121:in
>> `process_args'
>>         from
>> /usr/local/lib/site_ruby/1.8/rubygems/command_manager.rb:92:in `run'
>>         from /usr/local/lib/site_ruby/1.8/rubygems/gem_runner.rb:30:in
>> `run'
>>         from /usr/bin/gem:23
>>
>>
>> Alguna idee?
>
> $sudo apt-get remove rails --purge
>
> $sudo gem i rails --include-dependencies
>
>
> Saludos!
373c4dd765755059d502b2077c1722b9?d=identicon&s=25 Emilio Tagua (Guest)
on 2007-07-20 18:31
(Received via mailing list)
On 7/20/07, Emili Parreño <ruby-forum-incoming@andreas-s.net> wrote:
>
> Eso ya lo sé, pero nu puedo hacerlo. Necesito Rails como paquete de
> debian.

No, no lo necesitas, no instales el paquete rails ni rake, usa los de
gems no de los repositorios de debian (o distro que uses).

Solo traen problemas, te lo digo por mis experiencias.

Saludos!
This topic is locked and can not be replied to.