Forum: Ruby on Rails webrick across network

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
9e6d05909dc733af570faadce1392e67?d=identicon&s=25 Michael Satterwhite (msatterwhite)
on 2007-07-20 02:50
I do my development on a Linux box. I'd like to test my code on a
Windows box running IE - as that is what most of my users will have. The
problem is that I can't access the Webrick server on my Linux box from
another computer on the network. It just can't connect.

I'm guessing that there is some configuration I'm missing - but I can't
find it. Can someone offer some help?

Thanks in Advance
D3e38358af962517113b3815ea7517c3?d=identicon&s=25 Krishna Sankar (Guest)
on 2007-07-20 05:24
(Received via mailing list)
Michael Satterwhite wrote:
    I can think of two things to check (probably obvious, yet I thought
I will mention them):
    a) Make sure you can ping the Linux box from the windows machine.
Someimes one way works, but not the other way.
    b) Also make sure Webrick is using and not
9e6d05909dc733af570faadce1392e67?d=identicon&s=25 Michael Satterwhite (msatterwhite)
on 2007-07-20 16:01
Krishna Sankar wrote:
> Michael Satterwhite wrote:
>     b) Also make sure Webrick is using and not

This sounds promising. I'm not sure where the configuration for Webrick
*IS*. I've even grepped for 3000 figuring that if there's a
configuration somewhere, it has to have the port in it.

Where can I find / change the Webrick configuration?
28668141f2faf4eb9f90fbaab79d220c?d=identicon&s=25 Dave Stevenson (dnstevenson)
on 2007-07-26 00:46
(Received via mailing list)
Try running the script/server command with -h

That prints:

Usage: server [options]
    -p, --port=port                  Runs Rails on the specified port.
                                     Default: 3000
    -b, --binding=ip                 Binds Rails to the specified ip.
    -d, --daemon                     Make server run as a Daemon.
    -e, --environment=name           Specifies the environment to run
this server under (test/development/production).
                                     Default: development

    -h, --help                       Show this help message.

Something you might want to check:  set your binding IP, your Port,
and make sure your Firewall rules will allow the incoming connection.

Hope this helps -

Dave - affordable VPS Hosting - web based SSH

On Jul 20, 8:01 am, Michael Satterwhite <rails-mailing-l...@andreas-
This topic is locked and can not be replied to.