Forum: Ruby libxml-ruby causes "Bus error" on Mac OS 10.4.10

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Cdac981269f584bab28bae40863268f2?d=identicon&s=25 (Guest)
on 2007-07-18 14:21
(Received via mailing list)

I tried to validate a XML-file with a XSD-file with libxml-ruby. On my
Mac (Mac OS 10.4.10, Ruby ruby 1.8.6 (2007-03-13 patchlevel 0) [i686-
darwin8.10.1]) the folowing error message appears:

$ ruby testxsd.rb
  testxsd.rb:37: [BUG] Bus Error
  ruby 1.8.6 (2007-03-13) [i686-darwin8.10.1]

 Abort trap

After I reinstalled Ruby with MacPorts the error still occurs.
Then I've set up a Ubuntu Linux in Parallels, installed the libxml-
ruby library and the script worked/works fine.

But on my Mac, it still crashes.

Has anyone an idea what could have went wrong, what may caused the
error and how I can fix it? Or has anyone got the same error??

Best Regards,
- dominik
This topic is locked and can not be replied to.