Forum: Ruby RDE 1.1.1 released

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
4a322196db1b3f32968293151bb061f3?d=identicon&s=25 sakazuki (Guest)
on 2007-07-07 11:07
(Received via mailing list)

I released RDE 1.1.1.

RDE is a Ruby IDE and Ruby editor on Windows.
You can edit, run and debug your scripts quickly and easily.
RDE debugger is the GUI wrapper of debug.rb.
RDE editor has functions that syntax coloring, autocomplete and etc.

Please try it.

For beginners, show the setup demo.

Changes is below.

== 2007-07-07  1.1.1
* Fix code converter setting broken.
* update data of auto complete with ruby-1.8.6
* Add close button on tabs.
* Add OverWrite in Edit Menu.
* Integrate Debug Menu and Run Menu.
C0e521f6be2b9ebea1b800447f92980f?d=identicon&s=25 Dick Summerfield (Guest)
on 2007-07-19 17:19
(Received via mailing list)
Hi all,

On 07/ 07/ 07 sakazuki announced a release of a Ruby IDE
RDE. I had no time then but have since installed it under Windows XP

After some font tweaikng I got it to look nice but I cannot get the
debugger to
work. It claims that it can't find the required debug2.rb even though
this is present
in the same library as rde.exe.

Could anyone who knows this IDE suggest what I might be doing wrong?
(I've tried various path settings in ' Tool | Options... | Directory
' but to no avail)

4a322196db1b3f32968293151bb061f3?d=identicon&s=25 sakazuki (Guest)
on 2007-07-20 23:35
(Received via mailing list)

Maybe, the installer failed to setup. Please manually setup first.

Run install.rb in the same rde.exe directory and execute "rde.exe

# intall.rb copys debug2.rb, rde_extend.rb and rde.dll(, if you
use cygw
in version) to $RUBY_PATH\lib\ruby\1.8.

check also RDE manual
 and RDE homepage(



----- Original Message -----
>After some font tweaikng I got it to look nice but I cannot get the debugger
C0e521f6be2b9ebea1b800447f92980f?d=identicon&s=25 Dick Summerfield (Guest)
on 2007-07-25 21:55
(Received via mailing list)
This worked. Thank you...
The debugger now starts up when F9 is pressed.


Dick Summerfield,
Eindhoven, Netherlands.
This topic is locked and can not be replied to.