Forum: Ruby Ogre.rb 0.1

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
83ca41657a99b65d99889abe712ba5e2?d=identicon&s=25 Jason Roelofs (Guest)
on 2007-07-07 00:29
(Received via mailing list)
Ogre.rb v 0.1 has been released! It is available in gem and tar format
it's rubyforge page:

Documentation is available in rdoc form at the website:

-- What is Ogre.rb? --

Ogre.rb is a SWIG wrapper around the very popular Ogre 3D rendering
Ogre.rb will eventually be not only a full wrapper around Ogre, but will
also transform Ogre's API to follow the Ruby Way.

Ogre.rb is currently built for Ogre 1.4 Eihort (
Ogre.rb also requires OIS 1.0  (

-- Installation --

Installation is as simple as can be expected:

  gem install ogre.rb

Builds are available for Win32 and *nix environments, with a Mac build
hopefully coming soon. Samples are available in the Source tar, a
Samples download, and in the SVN repository:

  svn co svn://

-- Running the samples --

Running the sample applications is as simple as making sure your system
knows where the Ogre libraries and plugins are installed. On Windows
requires setting of the PATH environment variable, and on *nix setting
the LD_LIBRARY_PATH variable if Ogre is installed in a custom location.

Ogre.rb also assumes prior knowledge of the Ogre rendering engine and
running Ogre applications. For those that are unfamiliar with Ogre, all
need to do to run the samples is to edit plugins.cfg and set the correct

-- Ogre.rb development --

Build instructions are located in the README.  For feature requests,
submissions, bug reports, or general questions please use the Rubyforge
project tracker.


This topic is locked and can not be replied to.