Forum: Ruby on Rails sqlite3.3.7 gives "SQL logic error or missing database"

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Aafa8848c4b764f080b1b31a51eab73d?d=identicon&s=25 Phlip (Guest)
on 2007-07-05 05:05
(Received via mailing list)
> annoyingly from test_dummy with nothing in it. The bug refers to the calls
> `commence'
> So when I move all my non-Model unit tests out of the unit test folder,
> and put them into the functional folder, and everything works.

I spoke too soon. The unit tests work, but all the functional view
tests don't work!

So, like others who have tried Sqlite3 on Fiesty Fawn, I am back to
for the tests. Good thing it doesn't seem too slow...
Aafa8848c4b764f080b1b31a51eab73d?d=identicon&s=25 Phlip (Guest)
on 2007-07-07 15:34
(Received via mailing list)
Phlip wrote:
> > annoyingly from test_dummy with nothing in it. The bug refers to the calls
> > `commence'
> > So that doesn't appear to be pilot error, huh, if all these tests work
> > fine with MySQL for the test database, and if all these tests worked fine
> > with slightly older version ticks.
> > Some version dumps:
> > rails (1.2.3)
> > sqlite3-ruby ( (This is _why's sensibility repack.)
> >ZenTest(3.6.0)

My biggest recent version change was ZenTest (from 3.4.2). Adding this
line to the *ViewTest classes seems to help:

  self.use_transactional_fixtures = false

And SQLite3 can't do transactions. So the problem appears to be
ZenTest's propagation of the transactional fixtures setting...

This topic is locked and can not be replied to.