Forum: Italian Ruby user group (Neofita) installazione gem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
774be2fbc3d75abd2357d6481276120f?d=identicon&s=25 Raoul Spinazzola (lattenero)
on 2007-07-04 16:20
Salve a tutti,
uso una debian etch con i pacchetti del repository debian.
sto provando ad installare il supporto ruby per postgres tramite gem.
mi trovo di fronte a questo errore:

mi serve una libreria, un compilatore, cosa?

Ringrazio in anticipo.

# gem install    postgres
Building native extensions.  This could take a while...
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=/usr/bin/ruby1.8
        --with-pgsql-dir
        --without-pgsql-dir
        --with-pgsql-include
        --without-pgsql-include=${pgsql-dir}/include
        --with-pgsql-lib
        --without-pgsql-lib=${pgsql-dir}/lib
        --with-wsock32lib
        --without-wsock32lib
        --with-socketlib
        --without-socketlib
        --with-inetlib
        --without-inetlib
        --with-nsllib
        --without-nsllib

ERROR:  While executing gem ... (RuntimeError)
    ERROR: Failed to build gem native extension.
Gem files will remain installed in /var/lib/gems/1.8/gems/postgres-0.7.1
for inspection.


Results logged to /var/lib/gems/1.8/gems/postgres-0.7.1/gem_make.out
F6c5178d0cab7e3c937378b7663d591e?d=identicon&s=25 Lucio Benfante (Guest)
on 2007-07-04 16:27
(Received via mailing list)
Raoul Spinazzola ha scritto:
> Salve a tutti,
> uso una debian etch con i pacchetti del repository debian.
> sto provando ad installare il supporto ruby per postgres tramite gem.
> mi trovo di fronte a questo errore:
>
> mi serve una libreria, un compilatore, cosa?
>
>
Ciao,
ti serve una libreria, ma dal tuo messaggio non si capisce cosa.

Oppure potresti installare la versione pure-ruby della gem per il
supporto postgres:

gem install postgres-pr

Lucio
774be2fbc3d75abd2357d6481276120f?d=identicon&s=25 Raoul Spinazzola (lattenero)
on 2007-07-04 16:34
Lucio Benfante wrote:
> Raoul Spinazzola ha scritto:
>> Salve a tutti,
>> uso una debian etch con i pacchetti del repository debian.
>> sto provando ad installare il supporto ruby per postgres tramite gem.
>> mi trovo di fronte a questo errore:
>>
>> mi serve una libreria, un compilatore, cosa?
>>
>>
> Ciao,
> ti serve una libreria, ma dal tuo messaggio non si capisce cosa.
>
> Oppure potresti installare la versione pure-ruby della gem per il
> supporto postgres:
>
> gem install postgres-pr
>
> Lucio

Grazie

gem install postgres-pr

Non mi da alcun messaggio di errore.

Inizio ad usare postgres-pr anche se ho letto che è un po' più lento,
quando sarò un po' più pratico cercherò di comprendere l'errore.

Raoul
7e97485c48d01e75edef8db8a9a7c63e?d=identicon&s=25 Carletto (Guest)
on 2007-07-04 16:50
(Received via mailing list)
Credo ti manchino i deb per lo sviluppo... non riesco proprio a
ricordare il nome, comunque è qualcosa del tipo "base develop".
Fai una breve ricerca su Google e poi vai di apt-get install... ;)


--- Raoul Spinazzola <raoul.spinazzola@dmgroup.it> ha scritto:

> Building native extensions.  This could take a while...
>         --with-opt-lib
>         --with-pgsql-lib
> ERROR:  While executing gem ... (RuntimeError)
> > _______________________________________________
> Ml mailing list
> Ml@lists.ruby-it.org
> http://lists.ruby-it.org/mailman/listinfo/ml
>



      ___________________________________
L'email della prossima generazione? Puoi averla con la nuova Yahoo!
Mail: http://it.docs.yahoo.com/nowyoucan.html
This topic is locked and can not be replied to.