Forum: Ferret Warning encoding error after Ferret changesets 765-769

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
C9ef330542fd9708282cf68d479975f3?d=identicon&s=25 Stuart Sierra (Guest)
on 2007-06-28 18:33
(Received via mailing list)
Hello all,

I recently upgraded from the Ferret gem 0.11.4 to the Subversion trunk,
changeset #770.  I did this because I needed the large file patch from

When adding documents to the index, I get the following message printed
to STDERR many times:

     Warning encoding error. Please check that you are using the correct
     locale for your input

Google found me this:
This appears to be part of a series of changes starting at #765 and
ending at #769.

#769 has the message "Reverted fix for OpenSolaris as it was affecting
other operating systems. New fix in place."  But apparently not
everything was reverted.

This does not seem to affect indexing or retrieval, just the warning
message.  Has anyone else experienced this?  I'll file a ticket if I can
get confirmation.

This is on Ubuntu Feisty, Linux 2.6.20, i686, Ruby version 1.8.5.

This topic is locked and can not be replied to.