Forum: Ruby on Rails rake test fails under InstantRails but not OSX

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
C3c53d4f132fb4ae634e80e501f188f0?d=identicon&s=25 Olly Lylo (Guest)
on 2007-06-28 17:12
(Received via mailing list)
I've found an intriguing issue with Rake.  I develop under OSX and all
my tests pass when I run 'rake test'.  I recently tried this on
Windows XP using InstantRails and a few of the unit tests failed.
Interestingly, if I manually execute rake_test_loader.rb with the same
parameters as Rake itself uses (or at least, what Rake prints to the
console), the tests pass fine, e.g:

$ ruby  -Ilib;test "C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/
rake-0.7.3/lib/rake/rake_test_loader.rb" "test/unit/test_1.rb" "test/
unit/test_2etc.rb"

Would anyone be able to enlighten me as to what Rake is doing
differently which might explain this behaviour?
6925c1e7ea432d878f1832d857d6dfe8?d=identicon&s=25 Richard Luther (Guest)
on 2007-06-28 17:25
(Received via mailing list)
Shot in the dark but if the locales for the database are different
from the windows box and the OS X box you could get failing tests if
you are testing the order of a result.

ex.
assert_equal Post.find_recent.first, posts(:first)

Its happened to me.
 - Richard
This topic is locked and can not be replied to.