Forum: Ruby on Rails Installation issues - rails non-existant...

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
166f431a24052a884b71b1274e551481?d=identicon&s=25 Johannes Hass (khaja)
on 2007-06-26 20:31
So, I installed ruby1.8 and gems via apt-get on Debian Etch and typed
the usual
"gem install rails --include-dependencies".

Got a success message in the process and proceeded to install the
postgresql-driver to connect to the database via

"gem install postgres".

I had forgotten to get the development-packages, though (which yielded a
lot of errors but told me that the install was successful?), a quick
"apt-get install ruby1.8-dev postgres-dev" solved it.

Only that the messages in-between now stated after the "make
install"-part that there was nothing to do, but the install was
successful (again).

IRB and a "require 'postgresql'" stated, however, that there was no such
thing as this adapter. To see if that was really so, I wanted to create
a quick scaffold by using "rails test"... only to be told that there's
no such thing as a file named "rails". Nor was "find" able to locate

Now, here I am, a tad frustrated because the documents regarding this
error speak of directories which do not exist on my system...
166f431a24052a884b71b1274e551481?d=identicon&s=25 Johannes Hass (khaja)
on 2007-06-26 21:13
Nevermind, fixed it myself.
This topic is locked and can not be replied to.