Forum: Ruby on Rails Cant test 404 pages in webrick

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
2689ef6ed6006970c3d153075df3df18?d=identicon&s=25 Jigar Gosar (cujigar)
on 2007-06-24 20:42
I tried running webrick in production mode with -e production option. I
changed development database name so as to make sure webrick was running
in production mode.

Now I wanted to test my new 404.html page so I typed an invalid URL, I
still get some routing error instead of my 404.html page.

Why is this happening with webrick in production. I haven't even changed
any of the environment files.

please advise,
thanks
217c03c9d5558ccb483b78e60b6c8e63?d=identicon&s=25 LemmingJoel (Guest)
on 2007-06-27 03:33
(Received via mailing list)
I'm having the same problem, but only when I access the server from
127.0.0.1. If I access it from any other address, I get the desired
Application Error page. This is obviously the intended behaviour. I
hope that helps Jigar.

However, I would like to get the Application Error page even when
accessing from local. Anyone have any ideas?

Joel.


On Jun 25, 4:42 am, Jigar Gosar <rails-mailing-l...@andreas-s.net>
This topic is locked and can not be replied to.