Forum: GNU Radio multi scope/fft not working right?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
7de99ba7a8144e8f34524dc0ca683bd7?d=identicon&s=25 unknown (Guest)
on 2007-06-20 21:31
(Received via mailing list)
Hi all-

I'm trying to build a multi-reciever program modelled on the stuff in
the
multi_antenna directory, however there seems to be a problem with the
multi_fft and multi_scope programs.  I have 2 LF daughterboards, and I'm
using a function generator to send a 1 kHz sine wave with .1 V p-p
levels.
I start either the _fft or _scope program with the arguments -d 250 -f
0.

What I'm observing is a very distorted signal; the distortion appears to
be due to the presence of significant energy in some harmonics away from
0
Hz.  I can remove them if I sharpen the default filter, but I have to
have
a cuttoff very close to my 1 khz to clean it up.  What is going on?  I
have two images, one for the scope and one for the fft at:

www.nd.edu/~ematlis/z.gnuradio/multi_scope.jpg
www.nd.edu/~ematlis/z.gnuradio/multi_fft.jpg


The standard usrp_oscope.py and usrp_fft.py do not show these harmonics
and the signal is very clean.

Any suggestions?

thanks,
eric

************************************
Eric H. Matlis, Ph.D.
Aerospace & Mechanical Engineering Dept.
120 Hessert Center for Aerospace Research
University of Notre Dame
Notre Dame, IN 46556-5684
Phone: (574) 631-6054
Fax:   (574) 631-8355
This topic is locked and can not be replied to.