Forum: Ruby on Rails A new Cygwin & RMagick problem?

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
0de2a19e1f26e4675d7dd363cc0157e9?d=identicon&s=25 Cliff Rowley (Guest)
on 2007-06-15 01:55
(Received via mailing list)
Ok, so last time I installed Ruby, Rails and RMagick under Cygwin I had
the ever so common fork problem which I solved with rebaseall.  Now I'm
4500 miles from home on another computer (my Sister's laptop) and I've
got a whole new problem going on.  At first I thought this may be
something to do with Mongrel, but the error only occurs when Im using
RMagick.  The reason I think this is a different error, is because
instead of complaining about the RMagick dll, it's complaining about
ruby/gems/1.8/mongrel-1.0.1/lib/  and I really don't
understand what's going on now.  I've tried rebaseall again, to no
avail.  I've also tried remapping at a couple of different addresses and
I just can't get it working.

I've spent the last couple of hours trying to figure this out, and I
rarely ask for help unless I have to.  If anyone could shed some light
on this I'd be very much obliged.  The error is as follows:

[main] ruby 57788 C:\cygwin\bin\ruby.exe *** fatal error *** - unable to
remap C:\cygwin\lib\ruby\gems\1.8\gems\mongrel-1.0.1\lib\ to
same address as parent(0x2C0000) != 0x1C760000

I've tried reinstalling both RMagick and Mongrel and nothing changes.  I
also tried rebasing, which resulted in garbage on the console
and a few PC speaker beeps.

Anyone able to assist?

Thanks in advance..

0de2a19e1f26e4675d7dd363cc0157e9?d=identicon&s=25 (Guest)
on 2007-06-17 07:30
(Received via mailing list)

Also, it's definitely something to do with Mongrel and not
specifically RMagick, since using WEBrick won't replicate this error.
This topic is locked and can not be replied to.