Forum: Ruby on Rails Errors When Trying to Update RubyGems on OS X Tiger

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
4562bacd2755483756bb7b346c5df6b8?d=identicon&s=25 Unnsse Khan (Guest)
on 2007-06-14 13:50
(Received via mailing list)
Hello there,

I am using the following:

Ruby version:

ruby 1.8.4 (2005-12-24) [powerpc-darwin8.7.0]

Rails version:

Rails 1.1.4

RubyGems version:


I got the following error message when I tried to update all my
RubyGems on OS X Tiger (please notice that I did log as 'root' prior
to this):

Raven:/Users/untz root# gem update all --include-dependencies
Updating installed gems...
Bulk updating Gem source index for:
Attempting remote update of all
ERROR:  While executing gem ... (Gem::GemNotFoundException)
     Could not find all (> 0) in the repository
Raven:/Users/untz root# gem update --include-dependencies
Updating installed gems...
Attempting remote update of actionmailer
Successfully installed actionmailer-1.3.3
Successfully installed actionpack-1.13.3
Successfully installed activesupport-1.4.2
Installing ri documentation for actionmailer-1.3.3...
Installing ri documentation for actionpack-1.13.3...

RDoc failure in lib/action_controller/cgi_ext/raw_post_data_fix.rb at
or around line 36 column 22

Before reporting this, could you check that the file
you're documenting compiles cleanly--RDoc is not a
full Ruby parser, and gets confused easily if fed
invalid programs.

The internal error was:

ERROR:  While executing gem ... (NoMethodError)
     undefined method `match_io' for -517611318:Fixnum

It also has errors when I try to run updates on other RubyGems!

Any help is greatly appreciated!

2808b5c359edcb77ec783e3793c8d381?d=identicon&s=25 Rafael (Guest)
on 2007-06-14 14:07
(Received via mailing list)
4562bacd2755483756bb7b346c5df6b8?d=identicon&s=25 Unnsse Khan (Guest)
on 2007-06-14 14:14
(Received via mailing list)

Thanks for the response!

Well, actually this time the gem update worked!

And I didn't have to select a lower version of GCC than 4.0....

Makes me think that perhaps the Internet connections while doing a
gem update are buggy?

Happy programming,

This topic is locked and can not be replied to.