Forum: Ruby on Rails Rails caching code in controller?

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
C9a0dfcb0b012ca369719c2902622ca5?d=identicon&s=25 (Guest)
on 2007-06-11 17:17
(Received via mailing list)
I'm pretty new to both Ruby and Rails, but I've got the basics. I just
inherited a project with a Postgres DB, Lighttpd running as web server
with 3 Mongrel processes. For some reason, when I update the code in
the controller files, it never gets executed (for example, adding a
new method throws a NoMethodFound error). Updating .rhtml files in the
view works just fine, unless I'm trying to use vars set in the updated

I've tried everything I can think of, including using dev mode and
restarting both Lighttpd and Mongrel. I've also made sure that the
source in both the web root and the Subversion repository are synched.

Am I missing something in the configuration? I've never run into this
before in any of the few other Rails projects I've worked on.
This topic is locked and can not be replied to.