Forum: Ruby on Rails Can't install rubygems - SuSE 9.3 x86_64

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
4cd3615da7c39beacaaab174267ad8b2?d=identicon&s=25 Davi (Guest)
on 2007-06-08 20:01
(Received via mailing list)
Hi all.

I can't install rubygems.

I've installed Ruby from Yast and downloaded rubygems from
rubyforge.org/projects/rubygems.

What should I do?

Here the log:

# ruby setup.rb
---> bin
<--- bin
---> lib
---> lib/rbconfig
<--- lib/rbconfig
---> lib/rubygems
---> lib/rubygems/commands
<--- lib/rubygems/commands
---> lib/rubygems/digest
<--- lib/rubygems/digest
<--- lib/rubygems
<--- lib
---> bin
<--- bin
---> lib
---> lib/rbconfig
<--- lib/rbconfig
---> lib/rubygems
---> lib/rubygems/commands
<--- lib/rubygems/commands
---> lib/rubygems/digest
<--- lib/rubygems/digest
<--- lib/rubygems
<--- lib
rm -f InstalledFiles
---> bin
mkdir -p /usr/bin/
install gem /usr/bin/
install gem_mirror /usr/bin/
install gem_server /usr/bin/
install gemlock /usr/bin/
install gemri /usr/bin/
install gemwhich /usr/bin/
install index_gem_repository.rb /usr/bin/
install update_rubygems /usr/bin/
<--- bin
---> lib
mkdir -p /usr/lib64/ruby/site_ruby/1.8/
install gemconfigure.rb /usr/lib64/ruby/site_ruby/1.8/
install rubygems.rb /usr/lib64/ruby/site_ruby/1.8/
install ubygems.rb /usr/lib64/ruby/site_ruby/1.8/
---> lib/rbconfig
mkdir -p /usr/lib64/ruby/site_ruby/1.8/rbconfig
install datadir.rb /usr/lib64/ruby/site_ruby/1.8/rbconfig
<--- lib/rbconfig
---> lib/rubygems
mkdir -p /usr/lib64/ruby/site_ruby/1.8/rubygems
install builder.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install command_manager.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install config_file.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install custom_require.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install dependency_list.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install doc_manager.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install format.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install gem_commands.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install gem_open_uri.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install gem_openssl.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install gem_runner.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install installer.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install old_format.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install open-uri.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install package.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install remote_fetcher.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install remote_installer.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install rubygems_version.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install security.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install server.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install source_index.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install source_info_cache.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install source_info_cache_entry.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems
install specification.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install timer.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install user_interaction.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install validator.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install version.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
---> lib/rubygems/commands
mkdir -p /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install build_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install cert_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install check_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install cleanup_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install contents_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install dependency_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install environment_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install help_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install install_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install list_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install outdated_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install pristine_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install query_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install rdoc_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install search_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install sources_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install
specification_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install uninstall_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install unpack_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install update_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
<--- lib/rubygems/commands
---> lib/rubygems/digest
mkdir -p /usr/lib64/ruby/site_ruby/1.8/rubygems/digest
install digest_adapter.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/digest
install md5.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/digest
install sha1.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/digest
install sha2.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/digest
<--- lib/rubygems/digest
<--- lib/rubygems
<--- lib
  Successfully built RubyGem
  Name: sources
  Version: 0.0.1
  File: sources-0.0.1.gem
hook /usr/local/src/rubygems-0.9.4/./post-install.rb failed:
gzip error installing sources-0.0.1.gem
Try 'ruby setup.rb --help' for detailed usage.



TIA

--
Davi Vidal
davividal@siscompar.com.br
davividal@gmail.com
--
"Religion, ideology, resources, land,
spite, love or "just because"...
No matter how pathetic the reason,
it's enough to start a war. "
4cd3615da7c39beacaaab174267ad8b2?d=identicon&s=25 Davi (Guest)
on 2007-06-08 20:07
(Received via mailing list)
Em Sexta 08 Junho 2007 15:02, Davi escreveu:
> hook /usr/local/src/rubygems-0.9.4/./post-install.rb failed:
> gzip error installing sources-0.0.1.gem
> Try 'ruby setup.rb --help' for detailed usage.
>

According to [1], I must have zlib installed. But I've zlib installed:

# rpm -qa zlib
zlib-1.2.2-5.4


[1] - http://railsforum.com/viewtopic.php?pid=10824


Thanks

--
Davi Vidal
davividal@siscompar.com.br
davividal@gmail.com
--
"Religion, ideology, resources, land,
spite, love or "just because"...
No matter how pathetic the reason,
it's enough to start a war. "
4cd3615da7c39beacaaab174267ad8b2?d=identicon&s=25 Davi (Guest)
on 2007-06-09 02:27
(Received via mailing list)
Em Sexta 08 Junho 2007 15:08, Davi escreveu:
>
> [1] - http://railsforum.com/viewtopic.php?pid=10824
>

# python /usr/lib64/python2.4/test/test_zlib.py
test_adler32empty (__main__.ChecksumTestCase) ... ok
test_adler32start (__main__.ChecksumTestCase) ... ok
test_crc32empty (__main__.ChecksumTestCase) ... ok
test_crc32start (__main__.ChecksumTestCase) ... ok
test_penguins (__main__.ChecksumTestCase) ... ok
test_badcompressobj (__main__.ExceptionTestCase) ... ok
test_baddecompressobj (__main__.ExceptionTestCase) ... ok
test_bigbits (__main__.ExceptionTestCase) ... ok
test_speech (__main__.CompressTestCase) ... ok
test_speech128 (__main__.CompressTestCase) ... ok
test_compressincremental (__main__.CompressObjectTestCase) ... ok
test_compressoptions (__main__.CompressObjectTestCase) ... ok
test_decompimax (__main__.CompressObjectTestCase) ... ok
test_decompinc (__main__.CompressObjectTestCase) ... ok
test_decompincflush (__main__.CompressObjectTestCase) ... ok
test_decompressmaxlen (__main__.CompressObjectTestCase) ... ok
test_decompressmaxlenflush (__main__.CompressObjectTestCase) ... ok
test_flushes (__main__.CompressObjectTestCase) ... ok
test_maxlenmisc (__main__.CompressObjectTestCase) ... ok
test_odd_flush (__main__.CompressObjectTestCase) ... ok
test_pair (__main__.CompressObjectTestCase) ... ok

----------------------------------------------------------------------
Ran 21 tests in 0.513s

OK


It seems that zlib is working fine...


--
Davi Vidal
davividal@siscompar.com.br
davividal@gmail.com
--
"Religion, ideology, resources, land,
spite, love or "just because"...
No matter how pathetic the reason,
it's enough to start a war. "
38a02bf7121a81be5be6f3d488ce23b5?d=identicon&s=25 Alexey Verkhovsky (Guest)
on 2007-06-09 06:20
(Received via mailing list)
On 6/8/07, Davi <davividal@siscompar.com.br> wrote:
> > According to [1], I must have zlib installed. But I've zlib installed:

You may have zlib, but not Ruby zlib bindings. These bindings are in a
file like
/usr/lib/ruby/1.8/i686-linux/zlib.so and they are compiled if zlib is
present where/when you are building Ruby. If it's not present, it is
just ignored, and then rubygems can be installed, but not used.

You can check it this way:

[alexeyv@vmbuild i686-linux]$ ruby -e "puts(require('zlib'))"
true

If it raises an error instead of printing 'true', uninstall ruby and
rebuild/reinstall it again with zlib.

--
Alex Verkhovsky
RubyWorks
F7d41a4824622680a50f8ac6eac8336f?d=identicon&s=25 Luc Evers (Guest)
on 2007-06-09 08:26
(Received via mailing list)
Alexey, Hi,

 I'm using Suse 10.2 , this version has Ruby ,Gems ...
 Running new Ruby versions on an old Linux can cause a lot of problems
because of the
 C library's.


  Luc.
4cd3615da7c39beacaaab174267ad8b2?d=identicon&s=25 Davi (Guest)
on 2007-06-09 13:26
(Received via mailing list)
Em Sábado 09 Junho 2007 01:19, Alexey Verkhovsky escreveu:
> On 6/8/07, Davi <davividal@siscompar.com.br> wrote:
> > > According to [1], I must have zlib installed. But I've zlib installed:
>
> You may have zlib, but not Ruby zlib bindings. These bindings are in a file
> like /usr/lib/ruby/1.8/i686-linux/zlib.so and they are compiled if zlib is
> present where/when you are building Ruby. If it's not present, it is just
> ignored, and then rubygems can be installed, but not used.
>

# find / -noleaf -name 'zlib.so'
/opt/ruby/lib64/ruby/1.8/x86_64-linux/zlib.so
/usr/lib64/ruby/1.8/x86_64-linux/zlib.so

> You can check it this way:
>
> [alexeyv@vmbuild i686-linux]$ ruby -e "puts(require('zlib'))"
> true
>

# ruby -e "puts(require('zlib'))"
true

> If it raises an error instead of printing 'true', uninstall ruby and
> rebuild/reinstall it again with zlib.
>

I don't known what should I do... =\

I've installed Ruby via Yast's RPM.

--
Davi Vidal
davividal@siscompar.com.br
davividal@gmail.com
--
"Religion, ideology, resources, land,
spite, love or "just because"...
No matter how pathetic the reason,
it's enough to start a war. "
4cd3615da7c39beacaaab174267ad8b2?d=identicon&s=25 Davi (Guest)
on 2007-06-09 13:31
(Received via mailing list)
Em Sábado 09 Junho 2007 03:24, Luc Evers escreveu:
>  I'm using Suse 10.2 , this version has Ruby ,Gems ...
>  Running new Ruby versions on an old Linux can cause a lot of problems
> because of the
>  C library's.
>

Where can I find the Ruby(gems)(on Rails) system requirements?

TIA

--
Davi Vidal
davividal@siscompar.com.br
davividal@gmail.com
--
"Religion, ideology, resources, land,
spite, love or "just because"...
No matter how pathetic the reason,
it's enough to start a war. "
38a02bf7121a81be5be6f3d488ce23b5?d=identicon&s=25 Alexey Verkhovsky (Guest)
on 2007-06-09 14:56
(Received via mailing list)
On 6/9/07, Davi <davividal@siscompar.com.br> wrote:
> # ruby -e "puts(require('zlib'))"
> true

OK, this confirms that you have zlib and zlib bindings properly
installed and available. No low hanging fruit there :)

> I don't known what should I do... =\
Despair not. You've got sources of all this stuff at hand, so you can
debug it.
In this case, you should:

1. Find a file called installer.rb in RubyGems sources. Probably at
  /usr/local/src/rubygems-0.9.4/lib/rubygems/installer.rb

2. Locate a section there that looks like this:
    rescue Zlib::GzipFile::Error
      raise InstallError, "gzip error installing #{@gem}"
    end

3. Edit this section as follows:
    rescue Zlib::GzipFile::Error => e
      puts e.message
      puts e.backtrace
      raise InstallError, "gzip error installing #{@gem}"
    end

4. Google up the message, and if that doesn't help, post it back here.

--
Alex Verkhovsky
RubyWorks
4cd3615da7c39beacaaab174267ad8b2?d=identicon&s=25 Davi (Guest)
on 2007-06-09 15:09
(Received via mailing list)
Em Sábado 09 Junho 2007 09:56, Alexey Verkhovsky escreveu:
> 3. Edit this section as follows:
>     rescue Zlib::GzipFile::Error => e
>       puts e.message
>       puts e.backtrace
>       raise InstallError, "gzip error installing #{@gem}"
>     end

WOW!! =D

I'm looking for it, but I don't knowned how to do this... =)
I've tried something like:
raise InstallError, "gzip error installing #{@gem}
#{@Zlib::GzipFile::Error}",
but it doesn't works... =P

So, after your help. I've found that I've an CRC error in
sources-0.0.1.gem.

Thanks a lot! =)


--
Davi Vidal
davividal@siscompar.com.br
davividal@gmail.com
--
"Religion, ideology, resources, land,
spite, love or "just because"...
No matter how pathetic the reason,
it's enough to start a war. "
4cd3615da7c39beacaaab174267ad8b2?d=identicon&s=25 Davi (Guest)
on 2007-06-09 15:10
(Received via mailing list)
Em Sábado 09 Junho 2007 09:56, Alexey Verkhovsky escreveu:
> 3. Edit this section as follows:
>     rescue Zlib::GzipFile::Error => e
>       puts e.message
>       puts e.backtrace
>       raise InstallError, "gzip error installing #{@gem}"
>     end

Maybe this could be useful for something else:

# ruby setup.rb
---> bin
<--- bin
---> lib
---> lib/rbconfig
<--- lib/rbconfig
---> lib/rubygems
---> lib/rubygems/commands
<--- lib/rubygems/commands
---> lib/rubygems/digest
<--- lib/rubygems/digest
<--- lib/rubygems
<--- lib
---> bin
<--- bin
---> lib
---> lib/rbconfig
<--- lib/rbconfig
---> lib/rubygems
---> lib/rubygems/commands
<--- lib/rubygems/commands
---> lib/rubygems/digest
<--- lib/rubygems/digest
<--- lib/rubygems
<--- lib
rm -f InstalledFiles
---> bin
mkdir -p /usr/bin/
install gem /usr/bin/
install gem_mirror /usr/bin/
install gem_server /usr/bin/
install gemlock /usr/bin/
install gemri /usr/bin/
install gemwhich /usr/bin/
install index_gem_repository.rb /usr/bin/
install update_rubygems /usr/bin/
<--- bin
---> lib
mkdir -p /usr/lib64/ruby/site_ruby/1.8/
install gemconfigure.rb /usr/lib64/ruby/site_ruby/1.8/
install rubygems.rb /usr/lib64/ruby/site_ruby/1.8/
install ubygems.rb /usr/lib64/ruby/site_ruby/1.8/
---> lib/rbconfig
mkdir -p /usr/lib64/ruby/site_ruby/1.8/rbconfig
install datadir.rb /usr/lib64/ruby/site_ruby/1.8/rbconfig
<--- lib/rbconfig
---> lib/rubygems
mkdir -p /usr/lib64/ruby/site_ruby/1.8/rubygems
install builder.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install command_manager.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install config_file.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install custom_require.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install dependency_list.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install doc_manager.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install format.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install gem_commands.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install gem_open_uri.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install gem_openssl.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install gem_runner.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install installer.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install old_format.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install open-uri.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install package.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install remote_fetcher.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install remote_installer.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install rubygems_version.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install security.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install server.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install source_index.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install source_info_cache.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install source_info_cache_entry.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems
install specification.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install timer.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install user_interaction.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install validator.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
install version.rb /usr/lib64/ruby/site_ruby/1.8/rubygems
---> lib/rubygems/commands
mkdir -p /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install build_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install cert_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install check_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install cleanup_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install contents_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install dependency_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install environment_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install help_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install install_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install list_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install outdated_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install pristine_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install query_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install rdoc_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install search_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install sources_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install
specification_command.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install uninstall_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install unpack_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
install update_command.rb
/usr/lib64/ruby/site_ruby/1.8/rubygems/commands
<--- lib/rubygems/commands
---> lib/rubygems/digest
mkdir -p /usr/lib64/ruby/site_ruby/1.8/rubygems/digest
install digest_adapter.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/digest
install md5.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/digest
install sha1.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/digest
install sha2.rb /usr/lib64/ruby/site_ruby/1.8/rubygems/digest
<--- lib/rubygems/digest
<--- lib/rubygems
<--- lib
  Successfully built RubyGem
  Name: sources
  Version: 0.0.1
  File: sources-0.0.1.gem
invalid compressed data -- crc error
/usr/lib64/ruby/site_ruby/1.8/rubygems/package.rb:513:in `close'
/usr/lib64/ruby/site_ruby/1.8/rubygems/package.rb:513:in `initialize'
/usr/lib64/ruby/site_ruby/1.8/rubygems/package.rb:488:in `each_entry'
/usr/lib64/ruby/site_ruby/1.8/rubygems/package.rb:442:in `loop'
/usr/lib64/ruby/site_ruby/1.8/rubygems/package.rb:464:in `each_entry'
/usr/lib64/ruby/site_ruby/1.8/rubygems/package.rb:427:in `each'
/usr/lib64/ruby/site_ruby/1.8/rubygems/package.rb:488:in `initialize'
/usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `new'
/usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `new'
/usr/lib64/ruby/site_ruby/1.8/rubygems/package.rb:586:in `open_from_io'
/usr/lib64/ruby/site_ruby/1.8/rubygems/package.rb:805:in `open_from_io'
/usr/lib64/ruby/site_ruby/1.8/rubygems/format.rb:59:in `from_io'
/usr/lib64/ruby/site_ruby/1.8/rubygems/format.rb:47:in
`from_file_by_path'
/usr/lib64/ruby/site_ruby/1.8/rubygems/installer.rb:68:in `install'
/usr/local/src/rubygems-0.9.4/./post-install.rb:88:in `install_sources'
/usr/local/src/rubygems-0.9.4/./post-install.rb:84:in `chdir'
/usr/local/src/rubygems-0.9.4/./post-install.rb:84:in `install_sources'
/usr/local/src/rubygems-0.9.4/./post-install.rb:116:in `instance_eval'
setup.rb:1560:in `instance_eval'
setup.rb:1560:in `run_hook'
setup.rb:1526:in `exec_task_traverse'
setup.rb:1342:in `exec_install'
setup.rb:1000:in `exec_install'
setup.rb:814:in `invoke'
setup.rb:773:in `invoke'
setup.rb:1578
hook /usr/local/src/rubygems-0.9.4/./post-install.rb failed:
gzip error installing sources-0.0.1.gem
Try 'ruby setup.rb --help' for detailed usage.

--
Davi Vidal
davividal@siscompar.com.br
davividal@gmail.com
--
"Religion, ideology, resources, land,
spite, love or "just because"...
No matter how pathetic the reason,
it's enough to start a war. "
38a02bf7121a81be5be6f3d488ce23b5?d=identicon&s=25 Alexey Verkhovsky (Guest)
on 2007-06-09 15:31
(Received via mailing list)
On 6/9/07, Davi <davividal@siscompar.com.br> wrote:
> So, after your help. I've found that I've an CRC error in sources-0.0.1.gem.

Yup.
sources.gem is, in fact, just a tar file generated by
install_sources() method in post-install.rb, and contains two gzipped
files inside. One of these gzipped files has a CRC error. Why I don't
know, but it probably has something to do with 64-bitness.

If I were you, I would try to drill down further (using the same
method), and if I hit the wall, I'd seek further help on
rubygems-users maillist.

--
Alex
4cd3615da7c39beacaaab174267ad8b2?d=identicon&s=25 Davi (Guest)
on 2007-06-10 03:03
(Received via mailing list)
Em Sábado 09 Junho 2007 10:29, Alexey Verkhovsky escreveu:
> On 6/9/07, Davi <davividal@siscompar.com.br> wrote:
> > So, after your help. I've found that I've an CRC error in
> > sources-0.0.1.gem.
>
> Yup.
> sources.gem is, in fact, just a tar file generated by
> install_sources() method in post-install.rb, and contains two gzipped
> files inside. One of these gzipped files has a CRC error. Why I don't
> know, but it probably has something to do with 64-bitness.
>

Probably... =\

> If I were you, I would try to drill down further (using the same
> method), and if I hit the wall, I'd seek further help on
> rubygems-users maillist.
>

I'm so sorry... I didn't that this was the wrong list... =)
I'll search help there. Thank you very much for the help! =)


--
Davi Vidal
davividal@siscompar.com.br
davividal@gmail.com
--
"Religion, ideology, resources, land,
spite, love or "just because"...
No matter how pathetic the reason,
it's enough to start a war. "
38a02bf7121a81be5be6f3d488ce23b5?d=identicon&s=25 Alexey Verkhovsky (Guest)
on 2007-06-10 08:28
(Received via mailing list)
On 6/9/07, Davi <davividal@siscompar.com.br> wrote:
> I'm so sorry... I didn't that this was the wrong list... =)

ruby-talk is not a wrong list, you are just likely to get better help
on a more specialized list.

--
Alex
4cd3615da7c39beacaaab174267ad8b2?d=identicon&s=25 Davi (Guest)
on 2007-06-11 21:09
(Received via mailing list)
Em Domingo 10 Junho 2007 03:27, Alexey Verkhovsky escreveu:
> On 6/9/07, Davi <davividal@siscompar.com.br> wrote:
> > I'm so sorry... I didn't that this was the wrong list... =)
>
> ruby-talk is not a wrong list, you are just likely to get better help
> on a more specialized list.
>

Thank you very much for your help, Alexey and Luc.

This issue is, probably, against rubygems-0.9.4 and SuSE 9.3 x86_64, as
I can
install rubygems-0.9.2 without any kind of problem.

HTH someone. =)

[output]

# ruby setup.rb
---> bin
<--- bin
---> lib
---> lib/rbconfig
<--- lib/rbconfig
---> lib/rubygems
<--- lib/rubygems
<--- lib
---> bin
<--- bin
---> lib
---> lib/rbconfig
<--- lib/rbconfig
---> lib/rubygems
<--- lib/rubygems
<--- lib
rm -f InstalledFiles
---> bin
mkdir -p /opt/ruby/bin/
install gem /opt/ruby/bin/
install gem_mirror /opt/ruby/bin/
install gem_server /opt/ruby/bin/
install gemlock /opt/ruby/bin/
install gemri /opt/ruby/bin/
install gemwhich /opt/ruby/bin/
install index_gem_repository.rb /opt/ruby/bin/
install update_rubygems /opt/ruby/bin/
<--- bin
---> lib
mkdir -p /opt/ruby/lib64/ruby/site_ruby/1.8/
install gemconfigure.rb /opt/ruby/lib64/ruby/site_ruby/1.8/
install rubygems.rb /opt/ruby/lib64/ruby/site_ruby/1.8/
install ubygems.rb /opt/ruby/lib64/ruby/site_ruby/1.8/
---> lib/rbconfig
mkdir -p /opt/ruby/lib64/ruby/site_ruby/1.8/rbconfig
install datadir.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rbconfig
<--- lib/rbconfig
---> lib/rubygems
mkdir -p /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install builder.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install cmd_manager.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install command.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install config_file.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install custom_require.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install dependency_list.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install doc_manager.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install format.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install gem_commands.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install gem_open_uri.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install gem_openssl.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install gem_runner.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install installer.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install old_format.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install open-uri.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install package.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install remote_fetcher.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install remote_installer.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install rubygems_version.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install security.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install server.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install source_index.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install source_info_cache.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install source_info_cache_entry.rb
/opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install specification.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install timer.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install user_interaction.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install validator.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
install version.rb /opt/ruby/lib64/ruby/site_ruby/1.8/rubygems
<--- lib/rubygems
<--- lib
  Successfully built RubyGem
  Name: sources
  Version: 0.0.1
  File: sources-0.0.1.gem
Removing old RubyGems RDoc and ri...
Installing rubygems-0.9.2 ri...
Installing rubygems-0.9.2 rdoc...

As of RubyGems 0.8.0, library stubs are no longer needed.
Searching $LOAD_PATH for stubs to optionally delete (may take a
while)...
...done.
No library stubs found.

# irb
irb(main):001:0> require 'rubygems'
=> true

[/output]


Thank you.

--
Davi Vidal
davividal@siscompar.com.br
davividal@gmail.com
--
"Religion, ideology, resources, land,
spite, love or "just because"...
No matter how pathetic the reason,
it's enough to start a war. "
This topic is locked and can not be replied to.