Forum: Ruby on Rails fcgid and webrick

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
82b1570fa2e3d9e0ac0890c57f705219?d=identicon&s=25 revolution (Guest)
on 2007-06-07 11:26
(Received via mailing list)
I try to run my app with rails 1.2.3 by mod_fcgid with apache2.2 and
ruby1.8.5. The result from production.log is error:

    /vendor/rails/railties/lib/dispatcher.rb:40:in `dispatch'
    /usr/lib/ruby/1.8/fcgi.rb:612:in `each_cgi'
    /usr/lib/ruby/1.8/fcgi.rb:609:in `each'
    /usr/lib/ruby/1.8/fcgi.rb:609:in `each_cgi'
    /vendor/rails/railties/lib/fcgi_handler.rb:55:in `process!'
    /vendor/rails/railties/lib/fcgi_handler.rb:25:in `process!'

But when i run from webrick (script/server), it work fine
82b1570fa2e3d9e0ac0890c57f705219?d=identicon&s=25 Artit Satanakulpanich (Guest)
on 2007-06-08 07:22
(Received via mailing list)
I got solution now. Because I create sym-link to rails/public, so rails
cannot route to rails/config directory. The solution is, moving all
to same dir of sym-link

On 6/7/07, revolution <> wrote:
> `process_request'
> `process_each_request!'
>     /vendor/rails/railties/lib/fcgi_handler.rb:55:in `process!'
>     /vendor/rails/railties/lib/fcgi_handler.rb:25:in `process!'
>     /var/www/virtual/
> But when i run from webrick (script/server), it work fine

Artit Satanakulpanich (Thai Language)
This topic is locked and can not be replied to.