Forum: GNU Radio VIA USB-2 combo card card, not working on linux for usrp

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
3719f4fea703e38bcbf8de6fe6bcdf55?d=identicon&s=25 Martin Dvh (Guest)
on 2007-06-07 01:57
(Received via mailing list)
Hi all,
I am using a combo pccard (USB-2 and firewire) with VIA chipset to get
USB-2 on my laptop.

But using linux I can't get it to work.
I get usrp overruns, (uOuOuO) even with decimation factors of 200 when
This is only 320 ksamples/sec

with top I see that the CPU is 80 % idle, so that is not the problem.

When running I get slightly better performance, 2
MB/sec works and 4 MB/sec works sometimes, all above fail.

I don't know why benchmark_usb works better then usrp_rx_cfile.

When I run I get garbled sound and uO and aU, but
this is logical. The script doesn't get enough data from the USRP.

On windows just works fine with the same usb-2 card.
(This is a much older gnuradio/usrp release though)

Does anybody have a clue, what is wrong here.

I tried both kernel 2.6.18 and 2.6.20. I also tried noacpi acpi=off
apm=off as kernel-boot param.

Or does anybody have a suggestion of an USB-2 addon card for a notebook
(pccard) that works with the USRP.

3596cfe1d579c65b9babd35e8787977c?d=identicon&s=25 Matt Ettus (Guest)
on 2007-06-07 03:31
(Received via mailing list)
> Or does anybody have a suggestion of an USB-2 addon card for a notebook (pccard) that 
works with the USRP.

Jim Perkins recently told me the following:

    I recently tested an inexpensive Zonet USB 2.0 add-on card. It has
the Via VT6212L chipset.  The Via based card worked very well.  The test returned OK for all speeds including 32 MB/s.

7de99ba7a8144e8f34524dc0ca683bd7?d=identicon&s=25 unknown (Guest)
on 2007-06-07 18:29
(Received via mailing list)
I have an Adaptec DuoConnect AUA-1422 combo card with an NEC USB2
Using Mandriva 2007 spring on a Dell Latitude C840 with Pentium 4 m 2.6
GHz cpu I only get 16 MB/s transfer as determined by
little dissapointed, specially as I'm experiencing uO's with my latest
4-channel receiver app.


Eric H. Matlis, Ph.D.
Aerospace & Mechanical Engineering Dept.
120 Hessert Center for Aerospace Research
University of Notre Dame
Notre Dame, IN 46556-5684
Phone: (574) 631-6054
Fax:   (574) 631-8355
3719f4fea703e38bcbf8de6fe6bcdf55?d=identicon&s=25 Martin Dvh (Guest)
on 2007-06-07 23:24
(Received via mailing list)
Matt Ettus wrote:
> Matt
Strange, my card is also a zonet USB 2.0 add-on card with VIA Vectro
VT6212 controller
Maybe the problem is that it is both usb-2.0 and firewire.

lspci gives:
Via Technlologies, Inc VT82xxxx UHCI USB 1.1 1106:3038 subsys 1106:3038
Via Technologies, Inc 2.0 [1106:3104] subsys 1106:3104
Via Technologies, Inc. IEEE 1394 Host Controller 1106:3044 subsys

I found on:
The cards that do both USB 2.0 and FireWire have for some reason been a
problem for many people, even those without built-in PCI bridges.

But the site does not give a solution.

It could also be  I am looking in the wrong direction and the problem is
in kernel, libusb or recent SVN usrp driver.

543560fff16cd8ce6ceb506c64c24a2d?d=identicon&s=25 Hans Glitsch (Guest)
on 2007-06-08 02:10
(Received via mailing list)

I have a complex signal at around 0Hz that I want to translate up to
I tried to use the freq_xlating_fir_filter like so:

gr.freq_xlating_fir_filter_ccf( 1, [1], 25e3, data_rate)

I want no decimation and no filtering in this operation.

when I set the decimation to 1, I get an assert from gr_buffer.h:96 that
says "s < d_bufsize"

Is freq_xlating_fir_filter_ccf not the correct block to use for this?

Thank you,

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.
745d8202ef5a58c1058d0e5395a78f9c?d=identicon&s=25 Eric Blossom (Guest)
on 2007-06-09 04:35
(Received via mailing list)
On Thu, Jun 07, 2007 at 05:09:05PM -0700, Hans Glitsch wrote:
> says "s < d_bufsize"
> Is freq_xlating_fir_filter_ccf not the correct block to use for this?
> Thank you,
> Hans

Just use a gr.sig_source_c as an LO and feed it to a complex
multiplier along with your baseband.

See the pipeline class in gnuradio-examples/python/usrp/

This topic is locked and can not be replied to.